summaryrefslogtreecommitdiff
path: root/dev-python/pybind11
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pybind11')
-rw-r--r--dev-python/pybind11/Manifest2
-rw-r--r--dev-python/pybind11/pybind11-2.12.0.ebuild68
2 files changed, 0 insertions, 70 deletions
diff --git a/dev-python/pybind11/Manifest b/dev-python/pybind11/Manifest
index c0b418a3cbc3..0775169f5a41 100644
--- a/dev-python/pybind11/Manifest
+++ b/dev-python/pybind11/Manifest
@@ -1,5 +1,3 @@
DIST pybind11-2.11.1.gh.tar.gz 756445 BLAKE2B 66ad933ffcd7fd475121f0b7488e13b914cb090d0ed511b96070e2849dcc537fb55e865b72fe06da6c5d1e3ed8e438799c5b0b60cbdc71e5713530174bff3be9 SHA512 ed1512ff0bca3bc0a45edc2eb8c77f8286ab9389f6ff1d5cb309be24bc608abbe0df6a7f5cb18c8f80a3bfa509058547c13551c3cd6a759af708fd0cdcdd9e95
-DIST pybind11-2.12.0.gh.tar.gz 771004 BLAKE2B df95d12cd005c85434ba8a4d80740f437f3f9433b0fbc9e6e1e5bf840281d5cb8295500b6510474a91b45201323b19079743ca927f7d1be2c1dc0dca89833e9c SHA512 c20247a4dccec310307174a26a79f9a98dd7ae7c84a48ad61c61589b02ef74caac26c2945de602cbe38b0bea65fc9985f1cc37f9e2322cae2f824dee98d602f1
EBUILD pybind11-2.11.1.ebuild 1305 BLAKE2B 60bdb063e9efb295ac3d49497b199cd9b9dedd23e3891ec9c96c6e2867e89c1cee9c16f3a34a4772813a850c74484fefd9c2dd53a072a84025b894546a0b237c SHA512 524695d724d859ea333de8975c392792c4ed685212204ecf72020af767d1cff6fdc307ecbd8e433af3627a76b2c7a5a41e83b13e313041fdd474df73880fb19c
-EBUILD pybind11-2.12.0.ebuild 1313 BLAKE2B c899f766ebeb7aee443f4908451fa47e75687aee2a7a13d3b361b61b93f2fd323ac707353f10575acc59bc937b3fd3fc462341f8c57f3e8ad304ddeefaad33a4 SHA512 b134ea98d2aee79bc20a31c34a420479c5925a6f3fae3ae7bb07c79eb61d2deca1a9b5a282c6cbd3abdc4df19b3bb1de63766dab7a4c2e7227143cf53a751570
MISC metadata.xml 475 BLAKE2B faf317a1197850acb0d16546a303bd50ee1bfe6fc3aaf592e6c147c6612fd20b809f1c911d79ca9a356cfa0c4166d2b155fcbd593f8b55e0d7dd75ff6444073b SHA512 5779adcc9f25c15fd999aa6c91d3144fc14535270e57925bfb8ac67f45448c144a142af2ea9a321ec6ffbf568713f663cef85a0be3d4a056e58b1782a5fc9a41
diff --git a/dev-python/pybind11/pybind11-2.12.0.ebuild b/dev-python/pybind11/pybind11-2.12.0.ebuild
deleted file mode 100644
index c27195fb2ada..000000000000
--- a/dev-python/pybind11/pybind11-2.12.0.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit cmake distutils-r1
-
-DESCRIPTION="AST-based Python refactoring library"
-HOMEPAGE="
- https://pybind11.readthedocs.io/en/stable/
- https://github.com/pybind/pybind11/
- https://pypi.org/project/pybind11/
-"
-SRC_URI="
- https://github.com/pybind/pybind11/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
-
-RDEPEND="
- dev-cpp/eigen:3
-"
-BDEPEND="
- test? (
- >=dev-cpp/catch-2.13.5
- dev-libs/boost
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- export PYBIND11_USE_CMAKE=1
- cmake_src_prepare
- distutils-r1_python_prepare_all
-}
-
-python_configure() {
- local mycmakeargs=(
- # disable forced lto
- -DPYBIND11_LTO_CXX_FLAGS=
- -DPYBIND11_INSTALL=ON
- -DPYBIND11_TEST=$(usex test)
- )
- cmake_src_configure
-}
-
-python_compile() {
- distutils-r1_python_compile
- # Compilation only does anything for tests
- use test && cmake_src_compile
-}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- cmake_build check
-}
-
-python_install() {
- distutils-r1_python_install
- cmake_src_install
-}