summaryrefslogtreecommitdiff
path: root/dev-python/pyaudio/pyaudio-0.2.11-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyaudio/pyaudio-0.2.11-r1.ebuild')
-rw-r--r--dev-python/pyaudio/pyaudio-0.2.11-r1.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/pyaudio/pyaudio-0.2.11-r1.ebuild b/dev-python/pyaudio/pyaudio-0.2.11-r1.ebuild
deleted file mode 100644
index 2af98eb2c323..000000000000
--- a/dev-python/pyaudio/pyaudio-0.2.11-r1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-MY_PN="PyAudio"
-
-DESCRIPTION="Python bindings for PortAudio"
-HOMEPAGE="http://people.csail.mit.edu/hubert/pyaudio/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-# Tests work if you have the correct HW device(s) to test. 0.2.11-r1.
-RESTRICT="test"
-
-RDEPEND="media-libs/portaudio"
-DEPEND="${RDEPEND}
- test? ( dev-python/numpy )"
-
-distutils_enable_sphinx sphinx
-distutils_enable_tests unittest
-
-python_test() {
- elog "These tests require an OS loopback sound device that forwards audio"
- elog "output, generated by PyAudio for playback, and forwards it to an input"
- elog "device, which PyAudio can record and verify against a test signal."
-
- cd tests || die
- # pyaudio_tests have very complicated runtime requirements, therefore skipping them.
- "${EPYTHON}" -m unittest error_tests -v ||
- die "Tests fail with ${EPYTHON}"
-}