summaryrefslogtreecommitdiff
path: root/dev-python/pyGPG
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyGPG')
-rw-r--r--dev-python/pyGPG/Manifest6
-rw-r--r--dev-python/pyGPG/metadata.xml19
-rw-r--r--dev-python/pyGPG/pyGPG-0.1.ebuild39
-rw-r--r--dev-python/pyGPG/pyGPG-0.2.ebuild39
-rw-r--r--dev-python/pyGPG/pyGPG-9999.ebuild45
5 files changed, 148 insertions, 0 deletions
diff --git a/dev-python/pyGPG/Manifest b/dev-python/pyGPG/Manifest
new file mode 100644
index 000000000000..f59407a038f4
--- /dev/null
+++ b/dev-python/pyGPG/Manifest
@@ -0,0 +1,6 @@
+DIST pyGPG-0.1.tar.gz 15441 BLAKE2B 5f14788d17ecdf9459a3332fab050892273adac75c7adb5c82c5770956017c3336385e35d4e2827cd070162efeacd4f4e3b2f2fa2cf17837826913fdced89875 SHA512 58a89fbee4311b89c5515ad1bc1d901057e8acdfdbcf36813f50a766374100a62efe456d52263711e5c2f46957791def9343d94f019e413506cfdbd353602060
+DIST pyGPG-0.2.tar.gz 15439 BLAKE2B 92c82b8b23c279461a872f118c636fa9cdae3f44910fc34a357983b0b4afea2a7b13c6400499a0fdbb4365357ade64294642178ca07a79ab3b7df89e60146e73 SHA512 93d892a57a27b254bfdc9778b73d341dfec654c2104c578014628df78c43beaf93eafb571ac544d52f334e63f6e5b8c0cfad7c8a0d585ee7211e8649efce8c67
+EBUILD pyGPG-0.1.ebuild 1032 BLAKE2B 2c80d106a746347e3908bc0696969c47a1f4038035ad1c39d0752fbdf399404c4f00b4ed2019ace84d965d2c03a32acf202847aba5f2cccbf816c391cd13f219 SHA512 59ddbeb63e67e5428c6918e7d555a75cdcabd4285a973ecd066e426e421c18b859ecc321f5c82e5312f770d50d165e8d0d4afb468f97d148b9d837129121ebfc
+EBUILD pyGPG-0.2.ebuild 1051 BLAKE2B 9356a35ba66e20ba3fa378f7908c2542d07a96ac7bce856e52c271baac2ba6161f8451874120d0ca9fd4d4802451caf9dfcb7e66f518e76ca931d27578445ed9 SHA512 f74205ebabc6ed8827635230e1434229cb3d174cdd15c6d5b06a46ad70cdd111db3ac2444cec5c08919d1149d47df9d42a001d47e250eab32e2a0149a12daf73
+EBUILD pyGPG-9999.ebuild 1027 BLAKE2B 9bfd0dd40b07f989e8a9579b265dea8f2682c4b8aff411ef052a825204b074cb945d20378b97526f92306edccea5d55f91c0c1a2a6804ed8d95e8d501535a0f5 SHA512 030cba87e2edd1aa491cec5db3546ce26f67171b316dc56fcf2b01695e0a11bf05e346fe05bdbc4b5db3848c83a38da87ba43d67443405e302301faa7fae6bbe
+MISC metadata.xml 672 BLAKE2B 27b2cf23f9d5b57b3b125bbfe3bf7e3ee581cb2d438e60295d94bdccc1d7c6549c412df0771b0d20d053f8efaaa1659ef9cc3e948a9afe2c70137047d63772c4 SHA512 3e10843a2625c38e9481e3d7d70318312efdda48c3ebf2c97af5f1319e03840765116856de363da5a7088e0fa25f03c513ec11bbe8eae55d932470e9f3bee420
diff --git a/dev-python/pyGPG/metadata.xml b/dev-python/pyGPG/metadata.xml
new file mode 100644
index 000000000000..ceedf0fea6c0
--- /dev/null
+++ b/dev-python/pyGPG/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dolsen@gentoo.org</email>
+ <name>Brian Dolbec</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>tools-portage@gentoo.org</email>
+ <name>Gentoo Portage tools team</name>
+ </maintainer>
+ <longdescription>A python interface library for wrapping gnupg's gpg command.
+ It also connects to gpg's status-fd output and makes all the status data
+ available as subclassed namedtuple instances.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">dol-sen/pyGPG</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyGPG/pyGPG-0.1.ebuild b/dev-python/pyGPG/pyGPG-0.1.ebuild
new file mode 100644
index 000000000000..73ab8a86e647
--- /dev/null
+++ b/dev-python/pyGPG/pyGPG-0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=(python{2_7,3_4})
+
+inherit distutils-r1
+
+EGIT_REPO_URI="https://github.com/dol-sen/pyGPG.git"
+
+DESCRIPTION="A python interface wrapper for gnupg's gpg command"
+HOMEPAGE="https://github.com/dol-sen/pyGPG"
+SRC_URI="https://dev.gentoo.org/~dolsen/releases/pyGPG/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~s390 ~x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-crypt/gnupg
+ "
+
+pkg_postinst() {
+ einfo
+ einfo "This is experimental software."
+ einfo "The API's it installs should be considered unstable"
+ einfo "and are subject to change."
+ einfo
+ einfo "Please file any enhancement requests, or bugs"
+ einfo "at https://github.com/dol-sen/pyGPG/issues"
+ einfo "I am also on IRC @ #gentoo-keys of the freenode network"
+ einfo
+ ewarn "There may be some python 3 compatibility issues still."
+ ewarn "Please help debug/fix/report them in github or bugzilla."
+}
diff --git a/dev-python/pyGPG/pyGPG-0.2.ebuild b/dev-python/pyGPG/pyGPG-0.2.ebuild
new file mode 100644
index 000000000000..46854436ed53
--- /dev/null
+++ b/dev-python/pyGPG/pyGPG-0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+inherit distutils-r1
+
+EGIT_REPO_URI="https://github.com/dol-sen/pyGPG.git"
+
+DESCRIPTION="A python interface wrapper for gnupg's gpg command"
+HOMEPAGE="https://github.com/dol-sen/pyGPG"
+SRC_URI="https://dev.gentoo.org/~dolsen/releases/pyGPG/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 sparc x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-crypt/gnupg
+ "
+
+pkg_postinst() {
+ einfo
+ einfo "This is experimental software."
+ einfo "The API's it installs should be considered unstable"
+ einfo "and are subject to change."
+ einfo
+ einfo "Please file any enhancement requests, or bugs"
+ einfo "at https://github.com/dol-sen/pyGPG/issues"
+ einfo "I am also on IRC @ #gentoo-keys of the freenode network"
+ einfo
+ ewarn "There may be some python 3 compatibility issues still."
+ ewarn "Please help debug/fix/report them in github or bugzilla."
+}
diff --git a/dev-python/pyGPG/pyGPG-9999.ebuild b/dev-python/pyGPG/pyGPG-9999.ebuild
new file mode 100644
index 000000000000..1ccf96a3fe59
--- /dev/null
+++ b/dev-python/pyGPG/pyGPG-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+EGIT_BRANCH="master"
+
+inherit distutils-r1 python-r1 git-2
+
+EGIT_REPO_URI="https://github.com/dol-sen/pyGPG.git"
+
+DESCRIPTION="A python interface wrapper for gnupg's gpg command"
+HOMEPAGE="https://github.com/dol-sen/pyGPG"
+SRC_URI=""
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+KEYWORDS=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-crypt/gnupg
+ "
+
+python_install_all() {
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ einfo
+ einfo "This is experimental software."
+ einfo "The API's it installs should be considered unstable"
+ einfo "and are subject to change."
+ einfo
+ einfo "Please file any enhancement requests, or bugs"
+ einfo "at https://github.com/dol-sen/pyGPG/issues"
+ einfo "I am also on IRC @ #gentoo-keys of the freenode network"
+ einfo
+ ewarn "There may be some python 3 compatibility issues still."
+ ewarn "Please help debug/fix/report them in github or bugzilla."
+}