summaryrefslogtreecommitdiff
path: root/dev-python/pyFFTW/pyFFTW-0.11.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyFFTW/pyFFTW-0.11.1.ebuild')
-rw-r--r--dev-python/pyFFTW/pyFFTW-0.11.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pyFFTW/pyFFTW-0.11.1.ebuild b/dev-python/pyFFTW/pyFFTW-0.11.1.ebuild
new file mode 100644
index 000000000000..c0a80dd82e78
--- /dev/null
+++ b/dev-python/pyFFTW/pyFFTW-0.11.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_6,3_7} )
+inherit distutils-r1
+
+DESCRIPTION="A pythonic python wrapper around FFTW"
+HOMEPAGE="https://github.com/pyFFTW/pyFFTW"
+
+LICENSE="BSD"
+SLOT="0"
+if [ "${PV}" = "9999" ]; then
+ KEYWORDS=""
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pyFFTW/pyFFTW.git"
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/pyFFTW/pyFFTW/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+IUSE=""
+
+DEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ >=sci-libs/fftw-3.3:3.0="
+RDEPEND="${DEPEND}"