summaryrefslogtreecommitdiff
path: root/dev-python/py/py-1.11.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/py/py-1.11.0.ebuild')
-rw-r--r--dev-python/py/py-1.11.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/py/py-1.11.0.ebuild b/dev-python/py/py-1.11.0.ebuild
new file mode 100644
index 000000000000..a21ebfb29c53
--- /dev/null
+++ b/dev-python/py/py-1.11.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="library with cross-python path, ini-parsing, io, code, log facilities"
+HOMEPAGE="https://py.readthedocs.io/ https://pypi.org/project/py/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+# This package is unmaintained and keeps being broken periodically.
+RESTRICT=test
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx doc
+distutils_enable_tests pytest