summaryrefslogtreecommitdiff
path: root/dev-python/pushbullet-py/pushbullet-py-0.12.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pushbullet-py/pushbullet-py-0.12.0.ebuild')
-rw-r--r--dev-python/pushbullet-py/pushbullet-py-0.12.0.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/dev-python/pushbullet-py/pushbullet-py-0.12.0.ebuild b/dev-python/pushbullet-py/pushbullet-py-0.12.0.ebuild
index 0ac0e801d0dd..ab98843f51a2 100644
--- a/dev-python/pushbullet-py/pushbullet-py-0.12.0.ebuild
+++ b/dev-python/pushbullet-py/pushbullet-py-0.12.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( pypy3 python3_{7..9} )
+PYTHON_COMPAT=( pypy3 python3_{7..10} )
inherit distutils-r1
@@ -33,10 +33,8 @@ BDEPEND="
distutils_enable_tests pytest
python_test() {
- # skip tests which require network access
- PUSHBULLET_API_KEY= pytest -vv \
- -k "not (test_auth or test_decryption)" \
- || die "Tests failed with ${EPYTHON}"
+ # Skip tests which require internet access
+ PUSHBULLET_API_KEY= epytest -k "not (test_auth or test_decryption)"
}
python_install_all() {