summaryrefslogtreecommitdiff
path: root/dev-python/pupynere/pupynere-1.0.15-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pupynere/pupynere-1.0.15-r2.ebuild')
-rw-r--r--dev-python/pupynere/pupynere-1.0.15-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pupynere/pupynere-1.0.15-r2.ebuild b/dev-python/pupynere/pupynere-1.0.15-r2.ebuild
new file mode 100644
index 000000000000..7f70dfe14fc9
--- /dev/null
+++ b/dev-python/pupynere/pupynere-1.0.15-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pupynere is a PUre PYthon NEtcdf REader"
+HOMEPAGE="https://pypi.org/project/pupynere/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ || (
+ dev-python/numpy-python2[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ "${PYTHON}" -m doctest -v "${BUILD_DIR}"/lib/pupynere.py \
+ || die "Tests fail with ${EPYTHON}"
+}