summaryrefslogtreecommitdiff
path: root/dev-python/pulsectl-asyncio/pulsectl-asyncio-1.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pulsectl-asyncio/pulsectl-asyncio-1.1.1.ebuild')
-rw-r--r--dev-python/pulsectl-asyncio/pulsectl-asyncio-1.1.1.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/pulsectl-asyncio/pulsectl-asyncio-1.1.1.ebuild b/dev-python/pulsectl-asyncio/pulsectl-asyncio-1.1.1.ebuild
deleted file mode 100644
index 3b6f81f6a6df..000000000000
--- a/dev-python/pulsectl-asyncio/pulsectl-asyncio-1.1.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Asyncio frontend for pulsectl, Python bindings of libpulse"
-HOMEPAGE="
- https://github.com/mhthies/pulsectl-asyncio/
- https://pypi.org/project/pulsectl-asyncio/
-"
-# sdist is missing examples that are used in tests
-SRC_URI="
- https://github.com/mhthies/pulsectl-asyncio/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~riscv ~x86"
-
-RDEPEND="
- >=dev-python/pulsectl-23.5.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- media-sound/pulseaudio-daemon
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # unpin deps
- sed -i -e 's:,<=[0-9.]*::' setup.cfg || die
- distutils-r1_src_prepare
-}