summaryrefslogtreecommitdiff
path: root/dev-python/pudb/pudb-2024.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pudb/pudb-2024.1.ebuild')
-rw-r--r--dev-python/pudb/pudb-2024.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pudb/pudb-2024.1.ebuild b/dev-python/pudb/pudb-2024.1.ebuild
new file mode 100644
index 000000000000..43e7248982cd
--- /dev/null
+++ b/dev-python/pudb/pudb-2024.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A full-screen, console-based Python debugger"
+HOMEPAGE="https://pypi.org/project/pudb/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/urwid-2.4[${PYTHON_USEDEP}]
+ dev-python/urwid_readline[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest