summaryrefslogtreecommitdiff
path: root/dev-python/psycopg/files/psycopg-2.8.3-avoid-mxdatetime.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/psycopg/files/psycopg-2.8.3-avoid-mxdatetime.patch')
-rw-r--r--dev-python/psycopg/files/psycopg-2.8.3-avoid-mxdatetime.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/psycopg/files/psycopg-2.8.3-avoid-mxdatetime.patch b/dev-python/psycopg/files/psycopg-2.8.3-avoid-mxdatetime.patch
new file mode 100644
index 000000000000..3475bf31795e
--- /dev/null
+++ b/dev-python/psycopg/files/psycopg-2.8.3-avoid-mxdatetime.patch
@@ -0,0 +1,24 @@
+diff --git a/setup.py b/setup.py
+index c1f319a..c44fc69 100644
+--- a/setup.py
++++ b/setup.py
+@@ -525,19 +525,6 @@ parser.read('setup.cfg')
+
+ # check for mx package
+ have_mxdatetime = False
+-mxincludedir = ''
+-if parser.has_option('build_ext', 'mx_include_dir'):
+- mxincludedir = parser.get('build_ext', 'mx_include_dir')
+-if not mxincludedir:
+- mxincludedir = os.path.join(get_python_inc(plat_specific=1), "mx")
+-if mxincludedir.strip() and os.path.exists(mxincludedir):
+- # Build the support for mx: we will check at runtime if it can be imported
+- include_dirs.append(mxincludedir)
+- define_macros.append(('HAVE_MXDATETIME', '1'))
+- sources.append('adapter_mxdatetime.c')
+- depends.extend(['adapter_mxdatetime.h', 'typecast_mxdatetime.c'])
+- have_mxdatetime = True
+- version_flags.append('mx')
+
+ # generate a nice version string to avoid confusion when users report bugs
+ version_flags.append('pq3') # no more a choice