summaryrefslogtreecommitdiff
path: root/dev-python/prompt-toolkit/prompt-toolkit-3.0.41.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/prompt-toolkit/prompt-toolkit-3.0.41.ebuild')
-rw-r--r--dev-python/prompt-toolkit/prompt-toolkit-3.0.41.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/prompt-toolkit/prompt-toolkit-3.0.41.ebuild b/dev-python/prompt-toolkit/prompt-toolkit-3.0.41.ebuild
new file mode 100644
index 000000000000..f79321605a0f
--- /dev/null
+++ b/dev-python/prompt-toolkit/prompt-toolkit-3.0.41.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="
+ https://pypi.org/project/prompt-toolkit/
+ https://github.com/prompt-toolkit/python-prompt-toolkit/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest