summaryrefslogtreecommitdiff
path: root/dev-python/prometheus-client/prometheus-client-0.17.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/prometheus-client/prometheus-client-0.17.1.ebuild')
-rw-r--r--dev-python/prometheus-client/prometheus-client-0.17.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/prometheus-client/prometheus-client-0.17.1.ebuild b/dev-python/prometheus-client/prometheus-client-0.17.1.ebuild
new file mode 100644
index 000000000000..4c7172a015c2
--- /dev/null
+++ b/dev-python/prometheus-client/prometheus-client-0.17.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python client for the Prometheus monitoring system"
+HOMEPAGE="
+ https://github.com/prometheus/client_python/
+ https://pypi.org/project/prometheus-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/twisted[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest