summaryrefslogtreecommitdiff
path: root/dev-python/progress/progress-1.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/progress/progress-1.6.ebuild')
-rw-r--r--dev-python/progress/progress-1.6.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/progress/progress-1.6.ebuild b/dev-python/progress/progress-1.6.ebuild
new file mode 100644
index 000000000000..4670e5bd5833
--- /dev/null
+++ b/dev-python/progress/progress-1.6.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Easy to use progress bars"
+HOMEPAGE="https://pypi.org/project/progress/ https://github.com/verigak/progress/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="ISC"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+python_test() {
+ "${EPYTHON}" test_progress.py || die "Tests fail with ${EPYTHON}"
+}