summaryrefslogtreecommitdiff
path: root/dev-python/process-tests/process-tests-2.1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/process-tests/process-tests-2.1.2.ebuild')
-rw-r--r--dev-python/process-tests/process-tests-2.1.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/process-tests/process-tests-2.1.2.ebuild b/dev-python/process-tests/process-tests-2.1.2.ebuild
new file mode 100644
index 000000000000..9b6ad71f5f40
--- /dev/null
+++ b/dev-python/process-tests/process-tests-2.1.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Tools for testing processes"
+HOMEPAGE="https://github.com/ionelmc/python-process-tests https://pypi.org/project/process-tests/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+# There are no tests at all, under TODO
+# see https://pypi.org/project/process-tests/2.0.2/
+RESTRICT="test"
+
+DOCS=( README.rst )