summaryrefslogtreecommitdiff
path: root/dev-python/prettytable
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/prettytable')
-rw-r--r--dev-python/prettytable/Manifest2
-rw-r--r--dev-python/prettytable/prettytable-3.15.1.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/prettytable/Manifest b/dev-python/prettytable/Manifest
index 56647ce86c01..75007eda62c8 100644
--- a/dev-python/prettytable/Manifest
+++ b/dev-python/prettytable/Manifest
@@ -1,3 +1,5 @@
DIST prettytable-3.14.0.tar.gz 61747 BLAKE2B 94bb7faa84f174c57b9bb6ddbed2438d00544ed3dabda5a88bf52205e37b646489a425e4b30cf254bd454b94a2ce6906d332ab6a9ea6d4f3c2960f46e9fd214f SHA512 9e3b5cc819b25e3731ad4b8a0809c631879c903733906177fe5b1668ea85ed025192ae0f1e0c8616a7eec51dfd9e15732a7e83c80e30549aad6a3fe768feae19
+DIST prettytable-3.15.1.tar.gz 65907 BLAKE2B 0a65013540dbd4a38a947adaa2f9432e9e06682ab434145fb568ee0f9f80371e90f776d56d1d0aa2b81c7dbe09f936c62c9fbd2d6927ee9e24b3d456e9190d19 SHA512 550f1794b3da55cc14b252817fdb17e5f380978be0d5b3a055646d769f4276498bdda5dbc9df88c6bf29069becb572ffe9bb8eb30781e1c975a6ddcbca4c2380
EBUILD prettytable-3.14.0.ebuild 860 BLAKE2B 09a6df3429bfa612c796c8f30d19a5c036745dc04921b58182921cd25da87809cb66d76ba4d01246cf90917d0a5a85a977accce77f890847a0183bbe8438418e SHA512 3a19740de45f10151805c7050ce9d8817e0c7db12e096cf072e0fc6bb58a5a4d88a236a415e8e06590e1ace0e21b71d3b1492397bc8dfd9fa346d2f356f1cd0e
+EBUILD prettytable-3.15.1.ebuild 874 BLAKE2B 94cc8e074f3097630c8709248896a91d12e253f6759f532a90c2ceea44a34221e836ddd25ee065b7c684e2f884b35db4be7af2b91820328ab148a0970527581e SHA512 eaf6de9939b1440183f08cf11c65b8a44b70c101ef343f94ec6b178272b6d77a4b40b297b68e55fb8750c4217f20108fdf116b85817f2127f977a9ded163a1c3
MISC metadata.xml 528 BLAKE2B 21627ff0b6f1e48b09a0a701047720a70eb58439eb1f58ebb079bc325bea9bf1ed458010d6a171bdb6775f71d3fa5330d59c747825fe51de91d4cb68ada616c0 SHA512 4685264c305ca320d841d230179f29225862d4912fa7cfbe7151eea2d3792009716276eff1836a574fd532cffb86aac51c82a55357c02d27a361a208de649d53
diff --git a/dev-python/prettytable/prettytable-3.15.1.ebuild b/dev-python/prettytable/prettytable-3.15.1.ebuild
new file mode 100644
index 000000000000..6f35d36defca
--- /dev/null
+++ b/dev-python/prettytable/prettytable-3.15.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} pypy3 pypy3_11 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Easily displaying tabular data in a visually appealing ASCII table format"
+HOMEPAGE="
+ https://github.com/prettytable/prettytable/
+ https://pypi.org/project/prettytable/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/pytest-lazy-fixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # remove the implicit dep on coverage
+ sed -i -e '/coverage/d' pyproject.toml || die
+}