summaryrefslogtreecommitdiff
path: root/dev-python/pretty-yaml/pretty-yaml-21.8.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pretty-yaml/pretty-yaml-21.8.3.ebuild')
-rw-r--r--dev-python/pretty-yaml/pretty-yaml-21.8.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pretty-yaml/pretty-yaml-21.8.3.ebuild b/dev-python/pretty-yaml/pretty-yaml-21.8.3.ebuild
new file mode 100644
index 000000000000..1a6b58996d2e
--- /dev/null
+++ b/dev-python/pretty-yaml/pretty-yaml-21.8.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P=pyaml-${PV}
+DESCRIPTION="PyYAML-based module to produce pretty and readable YAML-serialized data"
+HOMEPAGE="https://github.com/mk-fg/pretty-yaml"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_P%-*}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ "${EPYTHON}" pyaml/tests/dump.py -v ||
+ die "tests failed under ${EPYTHON}"
+}