summaryrefslogtreecommitdiff
path: root/dev-python/pretty-yaml/pretty-yaml-20.4.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pretty-yaml/pretty-yaml-20.4.0.ebuild')
-rw-r--r--dev-python/pretty-yaml/pretty-yaml-20.4.0.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-python/pretty-yaml/pretty-yaml-20.4.0.ebuild b/dev-python/pretty-yaml/pretty-yaml-20.4.0.ebuild
index 13be942b0187..f592bf0fbdac 100644
--- a/dev-python/pretty-yaml/pretty-yaml-20.4.0.ebuild
+++ b/dev-python/pretty-yaml/pretty-yaml-20.4.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -25,6 +25,11 @@ BDEPEND="
dev-python/unidecode[${PYTHON_USEDEP}]
)"
+PATCHES=(
+ # https://github.com/mk-fg/pretty-yaml/pull/38
+ "${FILESDIR}/${P}-fix-py3.10.patch"
+)
+
python_test() {
"${EPYTHON}" pyaml/tests/dump.py -v ||
die "tests failed under ${EPYTHON}"