summaryrefslogtreecommitdiff
path: root/dev-python/polib/polib-1.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/polib/polib-1.1.0.ebuild')
-rw-r--r--dev-python/polib/polib-1.1.0.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/polib/polib-1.1.0.ebuild b/dev-python/polib/polib-1.1.0.ebuild
deleted file mode 100644
index 3e17fa1fa098..000000000000
--- a/dev-python/polib/polib-1.1.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-
-inherit distutils-r1
-
-DESCRIPTION="A library to manipulate gettext files (.po and .mo files)"
-HOMEPAGE="https://bitbucket.org/izi/polib/wiki/Home"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="doc"
-
-DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.0.7-BE-test.patch
-)
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- "${PYTHON}" tests/tests.py || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- local DOCS=( CHANGELOG README.rst )
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}