summaryrefslogtreecommitdiff
path: root/dev-python/pluggy
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pluggy')
-rw-r--r--dev-python/pluggy/Manifest6
-rw-r--r--dev-python/pluggy/metadata.xml15
-rw-r--r--dev-python/pluggy/pluggy-0.4.0.ebuild29
-rw-r--r--dev-python/pluggy/pluggy-0.5.2.ebuild28
4 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/pluggy/Manifest b/dev-python/pluggy/Manifest
new file mode 100644
index 000000000000..fd7e53ae40e6
--- /dev/null
+++ b/dev-python/pluggy/Manifest
@@ -0,0 +1,6 @@
+DIST pluggy-0.4.0.zip 19054 SHA256 dd841b5d290b252cf645f75f3bd37ceecfa0f36394ab313e4f785fe68a4081a4 SHA512 1a6e28df05751767df1ac3dfac4c29ba0367f05ae9c8c6a7f5163bb53de36f90226ed18baedeb41bc8ca23504ca61a9b32ef907d3ec3fee7512bcdf45a56d19c WHIRLPOOL 6fe852f807f8966d5df39a118871097758885c95c7aa1e722278704c8ccfaee14e6c18abf7e2033e4801aa0934a2ff0eb64ac3a8db5a53fc86841f6a9cf688cc
+DIST pluggy-0.5.2.tar.gz 18935 SHA256 bd60171dbb250fdebafad46ed16d97065369da40568ae948ef7117eee8536e94 SHA512 850b1a7b9e55d46d5deb16b8bc71e3f9d6c26b78fe34379b295a9780f3da8abb3c44f524f175d0392b61fc2d36d66d156db3f499a3c1666e2ff3e3c6344153cb WHIRLPOOL ae602eedb539f3e2b995edb474edf9de6a6637e6eee6e78987b43c6bcbfe8e9984beb9d1cbf5f33ac5e50367ea0a4ef2c69620fa3b776b0ed885e95b5878b020
+EBUILD pluggy-0.4.0.ebuild 646 SHA256 df0e85cad358fe18716a1e2fb7cf750b2acbe1ceca28559507a88abeb8eaeedd SHA512 8162cd6fbfa32f89b28219e4a8710e1b81047e76f4f0f709df0065f7210f3144db36e698efc4f8328f4286b6d872fe23aa19421f46786e63b9483f03fced005e WHIRLPOOL 4cf51fcd6e8f7a85f9cf6e63361beb112eba799fa2c6811aa07817d198a7cb09886fa748bb9a08066fb0290119f6f28c552749b9869ba354a8ba155e425eac3b
+EBUILD pluggy-0.5.2.ebuild 734 SHA256 0292836f1a277e55322f2370b8c873e8e9bb51b5f9205d620b306879f1076ce1 SHA512 772f0fb34d578a667a4946f5ff3d028bb96b354067eb77327ccee5715b848f50daa33652f1d7b2a80fd8d36c5aa8b789a4f1851d0208ec6dbbb2dd674d1e6b8a WHIRLPOOL 603875a1eb0ce34cdd5a7f8d3716b061352e18249bc731ad0366815ee744296395db6ae6b59f2a902616bdfa548347c3abca1b85b975ddf4ea3d6a7a7d498fb9
+MISC ChangeLog 625 SHA256 976ca4cc79431cc05aa6a8b6bf9841c1bdac49ec8c2b00c15f955af321eb0b2a SHA512 c813f93009204e2521c1413d8a2df6930ec7ce9a154fc675161aaff484e880a1999c8652a454ef847cbdd76612673ba525ad255438eeaf5f69b698f260255bda WHIRLPOOL 144e8aaa71c35a923fafc7dd95d75bbb3b8fbb2037018bce75585eb80fe7df7b0ddbf55e719b571dd1d5d10e00017189cf89766c1ebb33dd76ed90c269a38ef4
+MISC metadata.xml 444 SHA256 3d74ca22912b635cddc345092c6db3c5f60e861c8c5ee8ed92f4bca966d3b493 SHA512 2ecb5fb612627c44f3499080fcde9241daf2f25a974a8e24fe8190b7d5f8baa6a457b7a902e788f98fe9ed1fdb2cd0f46770337e8f836e430b0aa6f0d323ad50 WHIRLPOOL 7fe2f58f039036f5d73785c55f8d3a3877509719f4ff8588c7d8a01960323d1b0c21447987c7bcee60f0c2bfafd8dc7247496bef28dfbb1d952d4a28604b573d
diff --git a/dev-python/pluggy/metadata.xml b/dev-python/pluggy/metadata.xml
new file mode 100644
index 000000000000..972236293061
--- /dev/null
+++ b/dev-python/pluggy/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pluggy</remote-id>
+ <maintainer status="unknown">
+ <email>holger@merlinux.eu</email>
+ <name>Holger Krekel</name>
+ </maintainer>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pluggy/pluggy-0.4.0.ebuild b/dev-python/pluggy/pluggy-0.4.0.ebuild
new file mode 100644
index 000000000000..d7f5e8492ece
--- /dev/null
+++ b/dev-python/pluggy/pluggy-0.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="plugin and hook calling mechanisms for python"
+HOMEPAGE="https://pypi.python.org/pypi/pluggy"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v -v || die
+}
diff --git a/dev-python/pluggy/pluggy-0.5.2.ebuild b/dev-python/pluggy/pluggy-0.5.2.ebuild
new file mode 100644
index 000000000000..19a7a49c85c2
--- /dev/null
+++ b/dev-python/pluggy/pluggy-0.5.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="plugin and hook calling mechanisms for python"
+HOMEPAGE="https://pluggy.readthedocs.io/ https://github.com/pytest-dev/pluggy https://pypi.python.org/pypi/pluggy"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v || die "tests failed with ${EPYTHON}"
+}