summaryrefslogtreecommitdiff
path: root/dev-python/pluggy/pluggy-1.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pluggy/pluggy-1.0.0.ebuild')
-rw-r--r--dev-python/pluggy/pluggy-1.0.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/pluggy/pluggy-1.0.0.ebuild b/dev-python/pluggy/pluggy-1.0.0.ebuild
new file mode 100644
index 000000000000..f6228c328efc
--- /dev/null
+++ b/dev-python/pluggy/pluggy-1.0.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="plugin and hook calling mechanisms for python"
+HOMEPAGE="https://pluggy.readthedocs.io/ https://github.com/pytest-dev/pluggy https://pypi.org/project/pluggy/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="$(python_gen_cond_dep \
+ 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' pypy3)"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest