summaryrefslogtreecommitdiff
path: root/dev-python/pluggy/pluggy-0.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pluggy/pluggy-0.6.0.ebuild')
-rw-r--r--dev-python/pluggy/pluggy-0.6.0.ebuild28
1 files changed, 0 insertions, 28 deletions
diff --git a/dev-python/pluggy/pluggy-0.6.0.ebuild b/dev-python/pluggy/pluggy-0.6.0.ebuild
deleted file mode 100644
index 63f1dd813ea2..000000000000
--- a/dev-python/pluggy/pluggy-0.6.0.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} pypy pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="plugin and hook calling mechanisms for python"
-HOMEPAGE="https://pluggy.readthedocs.io/ https://github.com/pytest-dev/pluggy https://pypi.org/project/pluggy/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- py.test -v || die "tests failed with ${EPYTHON}"
-}