summaryrefslogtreecommitdiff
path: root/dev-python/pluggy/pluggy-0.13.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pluggy/pluggy-0.13.1-r2.ebuild')
-rw-r--r--dev-python/pluggy/pluggy-0.13.1-r2.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/pluggy/pluggy-0.13.1-r2.ebuild b/dev-python/pluggy/pluggy-0.13.1-r2.ebuild
new file mode 100644
index 000000000000..0c15916eaec1
--- /dev/null
+++ b/dev-python/pluggy/pluggy-0.13.1-r2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="plugin and hook calling mechanisms for python"
+HOMEPAGE="https://pluggy.readthedocs.io/ https://github.com/pytest-dev/pluggy https://pypi.org/project/pluggy/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
+
+PATCHES=( "${FILESDIR}/${PN}"-0.12.0-strip-setuptools_scm.patch )
+
+distutils_enable_tests pytest