summaryrefslogtreecommitdiff
path: root/dev-python/pluggy/pluggy-0.13.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pluggy/pluggy-0.13.0.ebuild')
-rw-r--r--dev-python/pluggy/pluggy-0.13.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pluggy/pluggy-0.13.0.ebuild b/dev-python/pluggy/pluggy-0.13.0.ebuild
new file mode 100644
index 000000000000..d2d28b6fca6d
--- /dev/null
+++ b/dev-python/pluggy/pluggy-0.13.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="plugin and hook calling mechanisms for python"
+HOMEPAGE="https://pluggy.readthedocs.io/ https://github.com/pytest-dev/pluggy https://pypi.org/project/pluggy/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="$(python_gen_cond_dep \
+ 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' -2 python3_{5,6,7} pypy3)"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}"-0.12.0-strip-setuptools_scm.patch )
+
+distutils_enable_tests pytest