summaryrefslogtreecommitdiff
path: root/dev-python/plotly
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/plotly')
-rw-r--r--dev-python/plotly/Manifest4
-rw-r--r--dev-python/plotly/plotly-6.1.0_rc0.ebuild (renamed from dev-python/plotly/plotly-6.0.1.ebuild)14
2 files changed, 8 insertions, 10 deletions
diff --git a/dev-python/plotly/Manifest b/dev-python/plotly/Manifest
index aee41ecdba5e..f6b9921be8ed 100644
--- a/dev-python/plotly/Manifest
+++ b/dev-python/plotly/Manifest
@@ -1,3 +1,3 @@
-DIST plotly.py-6.0.1.gh.tar.gz 7619570 BLAKE2B 6c88b24d15aa233e1d3871975d224bd9829f1726beba665bc68a2d1af293361774b10a9d4a95ce2c5c53afe7ac01f7770809fbfbab3733ff31531233905c97f1 SHA512 192d5ea5e5d75548d9fbacc36d419b695d5e976ab0e2e538b1453c89ba3b1b0494abc4631d0d631cd6fe60a74b4a67937173564f9661aa408ffc1fc0bfac2559
-EBUILD plotly-6.0.1.ebuild 3459 BLAKE2B c770eda3fee00c5c0498e7c7f2034069f25627b5dc4b81caafba3a3bc1a6a7594d3846796bd6aabccec5785891891a4ac9286612330f005fbcb56406f310f5ff SHA512 28c7c4ad1db06a70f18a1a36270c21e37fda201441a7fa4cf1b33f2f8e3fd58d0a4b8e8c5314fadf8a7745c519911ec7f4f85f1b2d37c638e2c9c25737795b0b
+DIST plotly.py-6.1.0rc0.gh.tar.gz 10087412 BLAKE2B 2863ebdec4dc3aa9a0f604e37e75e9b1401df06d028631f38d87fa9b48d9f780312c30ab18dee7c04e11d250796c4a48ed1ae6076e858c5b188cf06e6170c641 SHA512 8191313422ac99686ad1bf5f3a81c9a8bca5232891313a3b8adb503565752f911ae9749a842c7ee76e34b37b227d91ac10d897286d6ff70b5728616060c1cd9c
+EBUILD plotly-6.1.0_rc0.ebuild 3281 BLAKE2B 660b39d8d84d74bb710ac52ebcf9aa3a819f29f3e103678d907f1ed0c8a0186dc1234a383864eebc568ab7af4eaf51bb16419d18411042b94fd03e7b26b50a0c SHA512 3ef3d5414213aa93a289e94af29863de7a78190e6191bd3c9e6020bcc05cd64749382adba3779ba2e1e9f57fb426f694e0dad4eac624a0163546b28a5ed5151d
MISC metadata.xml 627 BLAKE2B 453adb04f4caba9790fe5223635245c8bca7ca5c6dc1930f09537045580b88b5fa1649e47158b13be6cc5cb09b4479a47690e37ef13208b47a95f82d14793a91 SHA512 a5183e9d217d1312e8d383ccb4ade66b92575492b6c8ed8987e3af18e9e456836b62b2d572ce62f9e01aae47b4a2bcbd12f79b4bb6acabfe69c2b63b20315bd3
diff --git a/dev-python/plotly/plotly-6.0.1.ebuild b/dev-python/plotly/plotly-6.1.0_rc0.ebuild
index b1974c30772e..61823207ef8c 100644
--- a/dev-python/plotly/plotly-6.0.1.ebuild
+++ b/dev-python/plotly/plotly-6.1.0_rc0.ebuild
@@ -3,12 +3,12 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_COMPAT=( python3_{11..13} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
-MY_P=plotly.py-${PV}
+MY_P=plotly.py-${PV/_}
DESCRIPTION="Browser-based graphing library for Python"
HOMEPAGE="
https://plotly.com/python/
@@ -16,7 +16,7 @@ HOMEPAGE="
https://pypi.org/project/plotly/
"
SRC_URI="
- https://github.com/plotly/plotly.py/archive/refs/tags/v${PV}.tar.gz
+ https://github.com/plotly/plotly.py/archive/refs/tags/v${PV/_}.tar.gz
-> ${MY_P}.gh.tar.gz
"
S="${WORKDIR}/${MY_P}"
@@ -66,6 +66,9 @@ python_test() {
local EPYTEST_IGNORE=(
# requires polars
tests/test_optional/test_px
+
+ # requires kaleido
+ tests/test_optional/test_kaleido/test_kaleido.py
)
local EPYTEST_DESELECT=(
@@ -82,11 +85,6 @@ python_test() {
'tests/test_io/test_to_from_json.py::test_read_json_from_file_string[FigureWidget-FigureWidget0]'
'tests/test_io/test_to_from_json.py::test_read_json_from_file_string[FigureWidget-FigureWidget1]'
- # require kaleido
- tests/test_optional/test_kaleido/test_kaleido.py::test_kaleido_engine_to_image_returns_bytes
- tests/test_optional/test_kaleido/test_kaleido.py::test_kaleido_fulljson
- tests/test_optional/test_kaleido/test_kaleido.py::test_bytesio
-
# minor matplotlib incompatibility
plotly/matplotlylib/mplexporter/tests/test_basic.py::test_legend_dots
plotly/matplotlylib/mplexporter/tests/test_utils.py::test_linestyle