summaryrefslogtreecommitdiff
path: root/dev-python/platformdirs/platformdirs-2.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/platformdirs/platformdirs-2.2.0.ebuild')
-rw-r--r--dev-python/platformdirs/platformdirs-2.2.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/platformdirs/platformdirs-2.2.0.ebuild b/dev-python/platformdirs/platformdirs-2.2.0.ebuild
new file mode 100644
index 000000000000..ca2a1a338088
--- /dev/null
+++ b/dev-python/platformdirs/platformdirs-2.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A small Python module for determining appropriate platform-specific dirs"
+HOMEPAGE="
+ https://pypi.org/project/platformdirs/
+ https://github.com/platformdirs/platformdirs/"
+SRC_URI="
+ https://github.com/platformdirs/platformdirs/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}