summaryrefslogtreecommitdiff
path: root/dev-python/pipenv
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pipenv')
-rw-r--r--dev-python/pipenv/Manifest2
-rw-r--r--dev-python/pipenv/files/pipenv-2021-5-29-r1-remove-attr-vendor-import.patch95
-rw-r--r--dev-python/pipenv/pipenv-2021.5.29-r1.ebuild54
3 files changed, 151 insertions, 0 deletions
diff --git a/dev-python/pipenv/Manifest b/dev-python/pipenv/Manifest
index e317db6290ac..5975a8e38d96 100644
--- a/dev-python/pipenv/Manifest
+++ b/dev-python/pipenv/Manifest
@@ -1,5 +1,7 @@
+AUX pipenv-2021-5-29-r1-remove-attr-vendor-import.patch 3064 BLAKE2B a292df872da96e643545dc3c0b8c27d40466f6b4fb76d0c19316021e103ab6ee3b4e18861f286fee96a004e4f8c1fb3889bd7285f790d31b7f81e49579ab13f1 SHA512 4301b2302648dea77809c3afda896f0f38e4fcde503a9810f8c1706e35b553bee8fc3bc803ff958b0afb0cde0b764854647416efadccab3541f284f3efde15ab
DIST pipenv-2020.11.15.tar.gz 11603983 BLAKE2B 552c35c942f9ece0f52419b6090b87c7dce0c49dd9dc12f8c5b3eb311058fc770ec9e2b141e960d357064c66c6de7cd0892d2dd19868e5cdaee0f302f98fb0ff SHA512 d312059b3fefc97d4cd79bf2b75d6bde1d117d92c0a299c30181a60ebea662a6c3dff0ca7b92c610dd8eb0c873509dd23c9a891761d0d47d0bba2cab738c830d
DIST pipenv-2021.5.29.tar.gz 11607230 BLAKE2B 8eef8e79fbdfaf85a949437d06d9f8b48f7eaa6e4769f6d4ed90b01c0ebf70c282fc90581cce5ffcab0aeb6bc9ad770a8b4425f355a06e0fc4cd56fb221386e2 SHA512 4fa018c13d4babe856bf5671cf5d18a95f4af4b6d4fc64c4919825fe04004ed3d8979ca335b851c6e24dad081475f6fb5b925eeff58c6fb5cffc450b967ed1cd
EBUILD pipenv-2020.11.15.ebuild 1428 BLAKE2B 154c51236e9875df17d635f17093473227102e830fcf639c0b92577cf36f973525b9251841ea02a3bbafade091673aeefd3a964ba26372a1c95b1ae2cf79c06f SHA512 e71bef8c4f72f4f6e2d35c5d2c59d7a8eed220d5718f9e31d94a8e3608b6e55dbcb42af2d63c5375cdcafba22ba55f7cfc6cf51e83820a7e71c7dda1f216ba7a
+EBUILD pipenv-2021.5.29-r1.ebuild 1427 BLAKE2B 62fc045ec96f38ba7adee831a3ea108b36b1f96868703aa04d50bdb88f15e91c8d835195d652e74b102f22919ef6b4f2af7f39197d74d3ac02b435002774f3e9 SHA512 3b45d3c1bd613d3212df52638cf4b20c23c306f14dac1f9e571dbed26dd34173fd3339e0c6056cc62e860abae4d48c98ad610c9df0409c92207234fb31a33eab
EBUILD pipenv-2021.5.29.ebuild 1428 BLAKE2B 154c51236e9875df17d635f17093473227102e830fcf639c0b92577cf36f973525b9251841ea02a3bbafade091673aeefd3a964ba26372a1c95b1ae2cf79c06f SHA512 e71bef8c4f72f4f6e2d35c5d2c59d7a8eed220d5718f9e31d94a8e3608b6e55dbcb42af2d63c5375cdcafba22ba55f7cfc6cf51e83820a7e71c7dda1f216ba7a
MISC metadata.xml 642 BLAKE2B a652239b8d21d5c30d7893bb530bb89af62e0642824d4954bdd41719d1f1b8afee5e8ca4cdc7859995adca8fe0ddbca916e4876ed10104fa9e69f76147227f71 SHA512 f9d9c4433c8bdbe9bdb4c62f8da158d59afba2052a899eb14c245c1109cf82f690e513581aa6028b4ceebc836a32df5b8961672fed833a08b8ef2ac8a442a860
diff --git a/dev-python/pipenv/files/pipenv-2021-5-29-r1-remove-attr-vendor-import.patch b/dev-python/pipenv/files/pipenv-2021-5-29-r1-remove-attr-vendor-import.patch
new file mode 100644
index 000000000000..3437c2a2f33f
--- /dev/null
+++ b/dev-python/pipenv/files/pipenv-2021-5-29-r1-remove-attr-vendor-import.patch
@@ -0,0 +1,95 @@
+diff --git a/pipenv/installers.py b/pipenv/installers.py
+index 1e81047d..ccfd639c 100644
+--- a/pipenv/installers.py
++++ b/pipenv/installers.py
+@@ -6,8 +6,11 @@ from abc import ABCMeta, abstractmethod
+
+
+ from .environments import PIPENV_INSTALL_TIMEOUT
+-from .vendor import attr, delegator
+ from .utils import find_windows_executable
++# future version of pipenv drops this
++# hence, this stays here for a while
++from .vendor import delegator
++import attr
+
+
+ @attr.s
+diff --git a/pipenv/vendor/passa/models/projects.py b/pipenv/vendor/passa/models/projects.py
+index c7807c05..f6e037d6 100644
+--- a/pipenv/vendor/passa/models/projects.py
++++ b/pipenv/vendor/passa/models/projects.py
+@@ -6,7 +6,7 @@ import collections
+ import io
+ import os
+
+-from pipenv.vendor import attr
++import attr
+ import packaging.markers
+ import packaging.utils
+ import plette
+diff --git a/pipenv/vendor/pythonfinder/models/mixins.py b/pipenv/vendor/pythonfinder/models/mixins.py
+index aeba0443..76327115 100644
+--- a/pipenv/vendor/pythonfinder/models/mixins.py
++++ b/pipenv/vendor/pythonfinder/models/mixins.py
+@@ -5,7 +5,7 @@ import abc
+ import operator
+ from collections import defaultdict
+
+-from pipenv.vendor import attr
++import attr
+ import six
+
+ from ..compat import fs_str
+diff --git a/pipenv/vendor/pythonfinder/models/path.py b/pipenv/vendor/pythonfinder/models/path.py
+index e8c13429..7a197181 100644
+--- a/pipenv/vendor/pythonfinder/models/path.py
++++ b/pipenv/vendor/pythonfinder/models/path.py
+@@ -7,7 +7,7 @@ import sys
+ from collections import defaultdict
+ from itertools import chain
+
+-from pipenv.vendor import attr
++import attr
+ import six
+ from cached_property import cached_property
+ from ..compat import Path, fs_str
+diff --git a/pipenv/vendor/pythonfinder/models/python.py b/pipenv/vendor/pythonfinder/models/python.py
+index 4f7e5563..d001a1e5 100644
+--- a/pipenv/vendor/pythonfinder/models/python.py
++++ b/pipenv/vendor/pythonfinder/models/python.py
+@@ -7,7 +7,7 @@ import platform
+ import sys
+ from collections import defaultdict
+
+-from pipenv.vendor import attr
++import attr
+ import six
+ from packaging.version import Version
+
+diff --git a/pipenv/vendor/pythonfinder/models/windows.py b/pipenv/vendor/pythonfinder/models/windows.py
+index c69b9484..fb36a272 100644
+--- a/pipenv/vendor/pythonfinder/models/windows.py
++++ b/pipenv/vendor/pythonfinder/models/windows.py
+@@ -4,7 +4,7 @@ from __future__ import absolute_import, print_function
+ import operator
+ from collections import defaultdict
+
+-from pipenv.vendor import attr
++import attr
+
+ from ..environment import MYPY_RUNNING
+ from ..exceptions import InvalidPythonVersion
+diff --git a/pipenv/vendor/pythonfinder/utils.py b/pipenv/vendor/pythonfinder/utils.py
+index bcea7f3e..41d2d59a 100644
+--- a/pipenv/vendor/pythonfinder/utils.py
++++ b/pipenv/vendor/pythonfinder/utils.py
+@@ -10,7 +10,7 @@ from collections import OrderedDict
+ from fnmatch import fnmatch
+ from threading import Timer
+
+-from pipenv.vendor import attr
++import attr
+ import six
+ from packaging.version import LegacyVersion, Version
+
diff --git a/dev-python/pipenv/pipenv-2021.5.29-r1.ebuild b/dev-python/pipenv/pipenv-2021.5.29-r1.ebuild
new file mode 100644
index 000000000000..403619ae6073
--- /dev/null
+++ b/dev-python/pipenv/pipenv-2021.5.29-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+MY_PV=${PV/_beta/b}
+DESCRIPTION="Python Development Workflow for Humans"
+HOMEPAGE="https://github.com/pypa/pipenv https://pypi.org/project/pipenv/"
+SRC_URI="https://github.com/pypa/pipenv/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+PATCHES="${FILESDIR}/${PN}-${PV//./-}-${PR}-remove-attr-vendor-import.patch"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.0.35[${PYTHON_USEDEP}]
+ dev-python/virtualenv-clone[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+src_prepare() {
+ # remove vendored version of PyYAML that is backported to Python2
+ rm -vR "${S}/${PN}/patched/yaml2/" || die
+ # remove vendored versions
+ # see https://bugs.gentoo.org/717666
+ rm -vR "${S}/${PN}/vendor/attr/" || die
+ rm -vR "${S}/${PN}/vendor/jinja2/" || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ pytest -vvv -x -m "not cli and not needs_internet" tests/unit/ || die
+}