summaryrefslogtreecommitdiff
path: root/dev-python/pip
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pip')
-rw-r--r--dev-python/pip/Manifest3
-rw-r--r--dev-python/pip/files/pip-24.1-test-offline.patch65
-rw-r--r--dev-python/pip/pip-24.1.ebuild137
3 files changed, 205 insertions, 0 deletions
diff --git a/dev-python/pip/Manifest b/dev-python/pip/Manifest
index 9a786e0f92c1..aa0911804ccf 100644
--- a/dev-python/pip/Manifest
+++ b/dev-python/pip/Manifest
@@ -1,5 +1,8 @@
AUX pip-23.1-no-coverage.patch 1836 BLAKE2B f8c95ed26d5a7cba2a516b8d134ddd9901fd7d39dc8bf174397ab2afab33e93c4af342195b5b4d7b0aedc642493f1ed2ee474c74e16e285f335dcdcf531b1777 SHA512 c63929cc5324b2a741a4c1ebb4990c376eb6a4c0f39370e456b674ce3cfbdf10471ec48cf9368fccba9264fd9d4a5667988116163e73772496f28d52986ff111
AUX pip-23.3.1-no-color.patch 1767 BLAKE2B b81a4b814e2e84e7c0424870d1a86ba7fde91400bfad127c696112544b294623ba9d580f503f01a8399a569a9a5880d38d1d09c98b9364c9b59915adb3a9b453 SHA512 c89be77fbd8049a1e6fd12ef4227926ff641c1797f91bbe91b6152016a1e7dff5e323d8ff0961948225ef854d52de972f74c8e37f48e8aee78e529f9ec8b3b3f
+AUX pip-24.1-test-offline.patch 2995 BLAKE2B bbaa9b6410b350cecfaf1422c252c166ac931a550896d153f174e6b351372e753762af621716b37f5480d34f51440be11bc7c4ff2dee4a84328d8e9ebe03bb09 SHA512 8af459ba1c6a732a694537473b08377c17c996c2e50bae50f3fbb5ceb0376fa29e72055d887e179e8dd22df400886f9bd101f577dae59956b6a132a878bda23b
DIST pip-24.0.gh.tar.gz 9398156 BLAKE2B 17a7ed9e15e9b8efa0d3e3c5586dc446958b62cf9ba52155a0d1ad97a3e212ee7a08a0e88a592718fc3d542eb8f434155a75cb98d90c008904bd8f59bd2b40b6 SHA512 0c2ecb2ecde4f155c83468d35bc4f52f37efffc16821ae7c706d035e1e8cc3709b41cb10f8140ff09205e8bbdba2c76128ad76d1cbd18401328b619228e834df
+DIST pip-24.1.gh.tar.gz 9188658 BLAKE2B 4a43ff0199d811dd30461e376f655a447f3f706a48dd97fe1d0ccf630f558e72209ccd06d98949a1541cd6b2942a816db23ce8aaa7fbbf9aef429502fb91ab92 SHA512 c60ab329fe91202ff64b5f0f90209085fbf8db0f0a05f0703f952ad69e39e2e3edb5dadc006a3f317cdd4ba4fb5abe56dfbd22792249a2d139702eec272186d1
EBUILD pip-24.0.ebuild 4559 BLAKE2B 6f34aa0dcd0c78b53d63c0dd523ec1b397186e8d9efc90781812d94e96138630653a896636931d2095c59065065b9140d104ebb9cf178858de0e5985aca4e05b SHA512 587b9eb40e71ee078d74853dfb0694ae2733fed6f54fb4ce48f410113179f15c55d17efc47e8ad0dc70d704302d731240ba0aad77c40450daecffc522d6f0320
+EBUILD pip-24.1.ebuild 4075 BLAKE2B 6cb7c20cfdd759fa1dcc80fa25421db1e0d2e885228a0eec231d4ef138a8ae9c91b418fe4fcb7f7e32a2804b22972bd41ecc025aad4b689f80753d8cacf83f9f SHA512 85f2640255282b964deab13ee3a59ce5856f90459a8271e52726322477cf5f98b632dda49eadf39b1dfc22a2a4740e2191a97515f7503d7484839b5f43d5fe1e
MISC metadata.xml 392 BLAKE2B 94ea3de1220cb9ca64ae1186597789cc83a54adfe44695932c07dd5065df0e5f9ee5078a495e3a12563b36809d781d8ab86bb6c92c485c023199d92547b74f27 SHA512 603199f6547105f3bb64f4fcaf004e9ef62fa2e0f8ec6eab56078119684b0f5119161e0f164fe02b2cf6dd6b115588c9ef77d727eeb6d138e281f1cb0bcb5de9
diff --git a/dev-python/pip/files/pip-24.1-test-offline.patch b/dev-python/pip/files/pip-24.1-test-offline.patch
new file mode 100644
index 000000000000..ebbf5a94a1ba
--- /dev/null
+++ b/dev-python/pip/files/pip-24.1-test-offline.patch
@@ -0,0 +1,65 @@
+diff --git a/tests/conftest.py b/tests/conftest.py
+index 35101cef2..5934e9f95 100644
+--- a/tests/conftest.py
++++ b/tests/conftest.py
+@@ -395,6 +395,7 @@ def pip_editable_parts(
+ "-m",
+ "pip",
+ "install",
++ "--no-build-isolation",
+ "--target",
+ pip_self_install_path,
+ "-e",
+diff --git a/tests/functional/test_config_settings.py b/tests/functional/test_config_settings.py
+index 3f88d9c39..857722dd1 100644
+--- a/tests/functional/test_config_settings.py
++++ b/tests/functional/test_config_settings.py
+@@ -118,6 +118,7 @@ def test_config_settings_implies_pep517(
+ )
+ result = script.pip(
+ "wheel",
++ "--no-build-isolation",
+ "--config-settings",
+ "FOO=Hello",
+ pkg_path,
+diff --git a/tests/functional/test_install.py b/tests/functional/test_install.py
+index eaea12a16..e19446385 100644
+--- a/tests/functional/test_install.py
++++ b/tests/functional/test_install.py
+@@ -685,7 +685,7 @@ def test_link_hash_in_dep_fails_require_hashes(
+ # Build a wheel for pkga and compute its hash.
+ wheelhouse = tmp_path / "wheehouse"
+ wheelhouse.mkdir()
+- script.pip("wheel", "--no-deps", "-w", wheelhouse, project_path)
++ script.pip("wheel", "--no-build-isolation", "--no-deps", "-w", wheelhouse, project_path)
+ digest = hashlib.sha256(
+ wheelhouse.joinpath("pkga-1.0-py3-none-any.whl").read_bytes()
+ ).hexdigest()
+@@ -903,7 +903,7 @@ def test_editable_install__local_dir_setup_requires_with_pyproject(
+ "setup(name='dummy', setup_requires=['simplewheel'])\n"
+ )
+
+- script.pip("install", "--find-links", shared_data.find_links, "-e", local_dir)
++ script.pip("install", "--no-build-isolation", "--find-links", shared_data.find_links, "-e", local_dir)
+
+
+ def test_install_pre__setup_requires_with_pyproject(
+diff --git a/tests/functional/test_self_update.py b/tests/functional/test_self_update.py
+index c50755220..1331a87c3 100644
+--- a/tests/functional/test_self_update.py
++++ b/tests/functional/test_self_update.py
+@@ -11,12 +11,12 @@ def test_self_update_editable(script: Any, pip_src: Any) -> None:
+ # Step 1. Install pip as non-editable. This is expected to succeed as
+ # the existing pip in the environment is installed in editable mode, so
+ # it only places a .pth file in the environment.
+- proc = script.pip("install", pip_src)
++ proc = script.pip("install", "--no-build-isolation", pip_src)
+ assert proc.returncode == 0
+ # Step 2. Using the pip we just installed, install pip *again*, but
+ # in editable mode. This could fail, as we'll need to uninstall the running
+ # pip in order to install the new copy, and uninstalling pip while it's
+ # running could fail. This test is specifically to ensure that doesn't
+ # happen...
+- proc = script.pip("install", "-e", pip_src)
++ proc = script.pip("install", "--no-build-isolation", "-e", pip_src)
+ assert proc.returncode == 0
diff --git a/dev-python/pip/pip-24.1.ebuild b/dev-python/pip/pip-24.1.ebuild
new file mode 100644
index 000000000000..f755b06a67b7
--- /dev/null
+++ b/dev-python/pip/pip-24.1.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# please bump dev-python/ensurepip-pip along with this package!
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_TESTED=( python3_{10..13} )
+PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" pypy3 )
+PYTHON_REQ_USE="ssl(+),threads(+)"
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="The PyPA recommended tool for installing Python packages"
+HOMEPAGE="
+ https://pip.pypa.io/en/stable/
+ https://pypi.org/project/pip/
+ https://github.com/pypa/pip/
+"
+SRC_URI="
+ https://github.com/pypa/pip/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+# bundled deps
+LICENSE+=" Apache-2.0 BSD BSD-2 ISC LGPL-2.1+ MPL-2.0 PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test-rust"
+
+RDEPEND="
+ >=dev-python/setuptools-39.2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/ensurepip-setuptools
+ dev-python/ensurepip-wheel
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/scripttest[${PYTHON_USEDEP}]
+ dev-python/tomli-w[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ test-rust? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ )
+ ' "${PYTHON_TESTED[@]}")
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}/pip-23.1-no-coverage.patch"
+ # https://github.com/pypa/pip/issues/12786 (and more)
+ "${FILESDIR}/pip-24.1-test-offline.patch"
+ )
+
+ distutils-r1_python_prepare_all
+
+ if use test; then
+ local wheels=(
+ "${BROOT}"/usr/lib/python/ensurepip/{setuptools,wheel}-*.whl
+ )
+ mkdir tests/data/common_wheels/ || die
+ cp "${wheels[@]}" tests/data/common_wheels/ || die
+ fi
+}
+
+python_compile_all() {
+ # 'pip completion' command embeds full $0 into completion script, which confuses
+ # 'complete' and causes QA warning when running as "${PYTHON} -m pip".
+ # This trick sets correct $0 while still calling just installed pip.
+ local pipcmd='import sys; sys.argv[0] = "pip"; __file__ = ""; from pip._internal.cli.main import main; sys.exit(main())'
+ "${EPYTHON}" -c "${pipcmd}" completion --bash > completion.bash || die
+ "${EPYTHON}" -c "${pipcmd}" completion --zsh > completion.zsh || die
+}
+
+python_test() {
+ if ! has "${EPYTHON}" "${PYTHON_TESTED[@]/_/.}"; then
+ einfo "Skipping tests on ${EPYTHON}"
+ return 0
+ fi
+
+ local EPYTEST_DESELECT=(
+ tests/functional/test_inspect.py::test_inspect_basic
+ # Internet
+ tests/functional/test_config_settings.py::test_backend_sees_config_via_sdist
+ tests/functional/test_install.py::test_double_install_fail
+ tests/functional/test_install_config.py::test_prompt_for_keyring_if_needed
+ )
+ local EPYTEST_IGNORE=(
+ # requires proxy.py
+ tests/functional/test_proxy.py
+ )
+
+ if ! has_version "dev-python/cryptography[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ tests/functional/test_install.py::test_install_sends_client_cert
+ tests/functional/test_install_config.py::test_do_not_prompt_for_authentication
+ tests/functional/test_install_config.py::test_prompt_for_authentication
+ tests/functional/test_install_config.py::test_prompt_for_keyring_if_needed
+ )
+ fi
+
+ case ${EPYTHON} in
+ python3.10)
+ EPYTEST_DESELECT+=(
+ # no clue why they fail
+ tests/unit/test_base_command.py::test_base_command_global_tempdir_cleanup
+ tests/unit/test_base_command.py::test_base_command_local_tempdir_cleanup
+ tests/unit/test_base_command.py::test_base_command_provides_tempdir_helpers
+ )
+ ;;
+ esac
+
+ local -x PIP_DISABLE_PIP_VERSION_CHECK=1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local EPYTEST_XDIST=1
+ epytest -m "not network" -o tmp_path_retention_policy=all
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS.txt docs/html/**/*.rst )
+ distutils-r1_python_install_all
+
+ newbashcomp completion.bash pip
+
+ insinto /usr/share/zsh/site-functions
+ newins completion.zsh _pip
+}