summaryrefslogtreecommitdiff
path: root/dev-python/pillow
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pillow')
-rw-r--r--dev-python/pillow/Manifest3
-rw-r--r--dev-python/pillow/pillow-11.1.0.ebuild23
2 files changed, 20 insertions, 6 deletions
diff --git a/dev-python/pillow/Manifest b/dev-python/pillow/Manifest
index 5d59f039ace2..1a0e5a0c1241 100644
--- a/dev-python/pillow/Manifest
+++ b/dev-python/pillow/Manifest
@@ -1,4 +1,5 @@
AUX pillow-10.2.0-cross.patch 2390 BLAKE2B d690b3f93d59c32d0f1b209b51ea4787230892488059ec206f548276a1f697394ca539fcd9f92fa7c547b37dd6b4fc738400a3034f54eec6260f0f98ae372b39 SHA512 4afaec6964298e2f1c21fea77791ce0cdacdbc65bf9798d46e99681c772065c1ad1175f5821162157cacac64f556e320af2ca7dcbd0806c07d04f8116f8f508c
DIST pillow-11.1.0.gh.tar.gz 46815201 BLAKE2B 7990683c90359e0a72e17a13e1a29455bc3ace8ce3616d6af59360edfc1ac87541bd1fd6967160bd8d7dd25cfedfc9d2e9b058c3ed433a6208379834f15bc312 SHA512 bb0622fae0b9c3903ddd945dced8e2b94348b2bd06c14bc74da00d8aa3a795aab2daaff39ca6c40b712dcce4f10218cd30739f0eb616c9dfbc16efcf80886f1e
-EBUILD pillow-11.1.0.ebuild 3621 BLAKE2B c74a4df2b97bf9986dfdf48051cf17e16dd31cfa02535331993096567001b691463528aa9ba4e3ec63be23b581adddae6f8cb1e7472deee828e6b5cdf6bebd4a SHA512 3d6fcf81662d7686988f958f971df26fcf482d481bce1f83d9d5ec834b8f218562245710e1bfc12332693598b863a1b542d95d121fc90699d64ce50e5689f4cc
+DIST pythoncapi_compat.h 61109 BLAKE2B 9b8d9f774a6803dee73aedc5465519f2956c284bf70314f5e046d0d5522a10891bf55358a85fea5a156d4063736424c0f019bc71dd18592bbf56c364db7b6bce SHA512 d0ca43186fdc3cd8d0e993135b50fc86eeea05e8b84cba529d89f60ce28bc9502f8d3825eb508be5d68d1fbfc53423a69756c0e79fe0fe7adf94c602b1cf79ff
+EBUILD pillow-11.1.0.ebuild 4055 BLAKE2B 4b3f021c6621551bfe7fa35755fb8824f2a7761aa27601d7e1fa32e9c0bc793ddf9ddbbde2aeb22011609c7fc731096799cfc2b628e7982ba6f43676f3ddadf2 SHA512 7bcb2fef13fc24187f439995d5eb3ee6f1de8beb38c5c167f21affcf11fdffcda985a274a953bbfa0f7ab2f106fbe7c73ee2419898c3eb00822b8837502577ec
MISC metadata.xml 480 BLAKE2B 9fe5188b0a5eb4f19b53f34efad5c7da2ba086dd5eb9ed2e4fce8b6a6fac14d9a848392980cd1d2eaff5b334d7c5e39f58d60b763f44879d852dfb0b4f5e3efc SHA512 2b15d9e07b13a6028e87a3d5f0e72b2d252cfb2fa843783acfd2a9dd38bb6f0641f94d067f3a900fede445c606da361d509de2d4541513126b57c6782f69a5bb
diff --git a/dev-python/pillow/pillow-11.1.0.ebuild b/dev-python/pillow/pillow-11.1.0.ebuild
index b60acd1a51fe..3080e16268e8 100644
--- a/dev-python/pillow/pillow-11.1.0.ebuild
+++ b/dev-python/pillow/pillow-11.1.0.ebuild
@@ -6,7 +6,7 @@ EAPI=8
DISTUTILS_EXT=1
# setuptools wrapper
DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( python3_{10..13} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 pypy3_11 )
PYTHON_REQ_USE='tk?,threads(+)'
inherit distutils-r1 toolchain-funcs virtualx
@@ -23,6 +23,7 @@ HOMEPAGE="
SRC_URI="
https://github.com/python-pillow/Pillow/archive/${PV}.tar.gz
-> ${P}.gh.tar.gz
+ https://github.com/python/pythoncapi-compat/raw/c84545f0e1e21757d4901f75c47333d25a3fcff0/pythoncapi_compat.h
"
S="${WORKDIR}/${MY_P}"
@@ -66,10 +67,22 @@ BDEPEND="
EPYTEST_XDIST=1
distutils_enable_tests pytest
-PATCHES=(
- # https://github.com/python-pillow/pillow/pull/7634
- "${FILESDIR}/${PN}-10.2.0-cross.patch"
-)
+src_prepare() {
+ local PATCHES=(
+ # https://github.com/python-pillow/pillow/pull/7634
+ "${FILESDIR}/${PN}-10.2.0-cross.patch"
+ )
+
+ distutils-r1_src_prepare
+
+ # https://github.com/python-pillow/Pillow/pull/8757
+ if ! grep -q 0041177c4f348c8952b4c8980b2c90856e61c7c7 \
+ src/thirdparty/pythoncapi_compat.h
+ then
+ die "Remove pythoncapi_compat.h update"
+ fi
+ cp "${DISTDIR}/pythoncapi_compat.h" src/thirdparty/ || die
+}
usepil() {
usex "${1}" enable disable