summaryrefslogtreecommitdiff
path: root/dev-python/pika
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pika')
-rw-r--r--dev-python/pika/Manifest4
-rw-r--r--dev-python/pika/pika-0.10.0.ebuild4
-rw-r--r--dev-python/pika/pika-0.13.0.ebuild19
3 files changed, 24 insertions, 3 deletions
diff --git a/dev-python/pika/Manifest b/dev-python/pika/Manifest
index d7e64fb7f65e..5c147c4b90b4 100644
--- a/dev-python/pika/Manifest
+++ b/dev-python/pika/Manifest
@@ -1,3 +1,5 @@
DIST pika-0.10.0.tar.gz 82642 BLAKE2B cc0cafd6d58c1b6511bb244731f4c18698370e77baaa0b876061d80c9748fb81b92dfdac0250c4db7a6ca816791ab8eb8f4f785d9223b45082918a304545a4bd SHA512 8a6e8b870aa36f141a24d4886cd8e4d4fb5cb735d87857a16ad963d7a14e0c40e81a3c7e193d879046a7e76fa87ab0b16bfd4a000e169e2452815fcd04db93eb
-EBUILD pika-0.10.0.ebuild 487 BLAKE2B cfbb743c1dc57fdc3f019e37aab1ea1f8f898a1d296db63c72273f872d4e323922a64da59c327076c36f20cc3a699dc253dcfa45753b4a0f9eb40cdae01f0081 SHA512 d08401c355f8d31f3a2b5300ff89e5615c7b9c6e6ca7b2cf34e0f9d7b2c172eca7dae47916f9729f548e6028109bbecc30aa01916e84ff216097f1c8f449ab99
+DIST pika-0.13.0.tar.gz 103730 BLAKE2B c78139ac7a60bd324619792b177c96793c8c645d58bd6962f7061d5dfca2f621b6199ebb4b2d3fbc7367324f18d3e766266b43db9afafdd8e64c2eec6069f175 SHA512 f555142c8f466ebdbc46a24278794754186176832841723cb0d5d6ff69ee9a946dca8a7ae3280a96b5da8cb2d3066e11a58771583edecf7990749c8857a7ed42
+EBUILD pika-0.10.0.ebuild 482 BLAKE2B 32894aaf55332fa734d1175074a05eb28ce2c740a1464627b55e308248fd654055b79fcf1f6d50a6d45ca566c1dc8d67c3ad36ffc1e6c8c7990a892a7654d0a7 SHA512 b86f8c40b1cea790caad0482938f9acf0e6ab380168507e58b12d4a5c2bbf2e5a3e1b21cbb5e91468a84380213efeb511b25dfc8231cb50fcbc2d40983cefa92
+EBUILD pika-0.13.0.ebuild 486 BLAKE2B 6a0fd4bdb481f6a8dc20f6c8d4f418b4813227ecad0056336d360d96461c570e11fa171b2ed89d93e65fc4fb2f03087baaecaf0dbf780175d46fe43c7a604053 SHA512 ecaf8cb7ee73ee918c2b262ad4b0ba95b02eb3be230c062f6002cfc2fe1e0c8f8da119f3462076c87ea29cd00834e93ac3044ce80525099c0964d58bde93059f
MISC metadata.xml 654 BLAKE2B d2ca07b7ddae1316c11f0fc7efe6a075f3b6118ddf6063e72de5cfaf90eb46cbb6f1c94292e82df12b2c7282f7518f79ed7fb5bac446841d388d797242bfac98 SHA512 dfaf85260ba3acb2c471870c6674d5ac647111168a77f09bde9419831f2a18acb297ef1590b7c944a242bce3deb29aa5dc149e691424d85eafd6f4b678aa2289
diff --git a/dev-python/pika/pika-0.10.0.ebuild b/dev-python/pika/pika-0.10.0.ebuild
index c72ca2b50a9b..5e6880484f75 100644
--- a/dev-python/pika/pika-0.10.0.ebuild
+++ b/dev-python/pika/pika-0.10.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+PYTHON_COMPAT=( python2_7 python3_{5,6} pypy )
inherit distutils-r1
diff --git a/dev-python/pika/pika-0.13.0.ebuild b/dev-python/pika/pika-0.13.0.ebuild
new file mode 100644
index 000000000000..062a032dbedb
--- /dev/null
+++ b/dev-python/pika/pika-0.13.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python implementation of the AMQP"
+HOMEPAGE="https://pika.readthedocs.org/ https://github.com/pika/pika"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""