summaryrefslogtreecommitdiff
path: root/dev-python/pgspecial
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pgspecial')
-rw-r--r--dev-python/pgspecial/Manifest4
-rw-r--r--dev-python/pgspecial/pgspecial-2.1.1.ebuild59
-rw-r--r--dev-python/pgspecial/pgspecial-2.1.2.ebuild2
3 files changed, 2 insertions, 63 deletions
diff --git a/dev-python/pgspecial/Manifest b/dev-python/pgspecial/Manifest
index 848911a07ae3..7a10f7c65f32 100644
--- a/dev-python/pgspecial/Manifest
+++ b/dev-python/pgspecial/Manifest
@@ -1,5 +1,3 @@
-DIST pgspecial-2.1.1.tar.gz 51017 BLAKE2B 170db33ca1629244b2c8c2d23a5768528e474660dcaf73079c516d33624202cc05487a338b21ac5bab28780d127923bf24d86231e85cade2f82714add5bdd789 SHA512 4ab8596536b90837c2ed0a11b6bbfecd6e5dc487b073a58a1406e8e70028ebb7010430784963fe27a08a5cc48292785f6d02affb750f4a1b74cbe33a0e06a5f0
DIST pgspecial-2.1.2.tar.gz 51057 BLAKE2B d164555363e421f716fd9a03653fa8ef6628fc15b71a03acb040c321a20d03e4193725ca3a809b3d4b8710e62005ba9637f35789795d7b4e195f653527617436 SHA512 3ef15c96b8ae84c2c346f44607360aad4bd0abe6f2dfec421af1ca176178b19c64d55baece118600038e105cacb4b5f9b9c3eebbd1e816a9e7a78877d2cb604c
-EBUILD pgspecial-2.1.1.ebuild 1364 BLAKE2B 3a4814c8bcd8da3785c0face85fe641235e1313161c3d15af379e394008a9051ffe300c240968397e638814335b76655db60078b0023bfefbaf9a4f3ed11af68 SHA512 17720d3b61ac5277c2036fd683e3f744df3eb9affdae8a99a6039e0cdb4654e77d1c90bfa538b5caea18df25c2e43b8254c1ec3420543aa603689ac2d975bd36
-EBUILD pgspecial-2.1.2.ebuild 1406 BLAKE2B fc5e7191aaee851d182bc23478d308f21d899b4c43b9c12455b5d5a8aa4c983c158fd07034ca5e0e082741f8e822107eeca3801dfb021a5c8d587b8a9a904771 SHA512 7ca28b203edd63f539b9fff55012b3e9705433cd9456405973c2400705615877a160a81f827df130caeec1cafeb5e44b705537a84690b72eaf79a033e8cc3061
+EBUILD pgspecial-2.1.2.ebuild 1403 BLAKE2B 199aa23ad91e05d93dc21e4b6e99d31a2407f252ea0a9f60ee55177a475b307afb2b3dbda8545874b9d301d735db191a6672eb82de235502701ebe5c4fbaeb45 SHA512 724beec5e3a74ccdeb98ddb9bd7fb2f35420a54b7b6e60e274fb06a7302fe6b60e68d9b84170cdd30b99d408487d5dea4c38815dbf28f94d785f2204783035d4
MISC metadata.xml 542 BLAKE2B f7c36257d672854f57623ce68e09e17b8bc734e0a2afa70308ff3c3dfee23274750a8d98034527e14c757546eb78b84f170b9a4d180e02cf491301ae34127c79 SHA512 cb1eac0516db3ff5f32efb6adcf2c39e5479f7bb2a44f3d7c75f4e38e07812db21fd8e8af94e97c613b54606c2660317b5dbb0221c88cc926968404898f19602
diff --git a/dev-python/pgspecial/pgspecial-2.1.1.ebuild b/dev-python/pgspecial/pgspecial-2.1.1.ebuild
deleted file mode 100644
index f835abccdbc1..000000000000
--- a/dev-python/pgspecial/pgspecial-2.1.1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Python implementation of PostgreSQL meta commands"
-HOMEPAGE="
- https://github.com/dbcli/pgspecial/
- https://pypi.org/project/pgspecial/
-"
-
-LICENSE="BSD MIT"
-SLOT="0"
-KEYWORDS="amd64 arm64 x86"
-
-RDEPEND="
- >=dev-python/click-4.1[${PYTHON_USEDEP}]
- >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
- >=dev-python/psycopg-3.0.10:0[${PYTHON_USEDEP}]
- >=dev-python/sqlparse-0.1.19[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- >=dev-db/postgresql-8.1[server]
- )
-"
-
-distutils_enable_tests pytest
-
-DOCS=( License.txt README.rst changelog.rst )
-
-EPYTEST_DESELECT=(
- # assumes a very specific locale
- tests/test_specials.py::test_slash_l
- tests/test_specials.py::test_slash_l_pattern
- # change in postgres? *shrug*
- tests/test_specials.py::test_slash_d_view_verbose
-)
-
-src_test() {
- local db=${T}/pgsql
-
- initdb --username=postgres -D "${db}" || die
- # TODO: random port
- pg_ctl -w -D "${db}" start \
- -o "-h '127.0.0.1' -p 5432 -k '${T}'" || die
- psql -h "${T}" -U postgres -d postgres \
- -c "ALTER ROLE postgres WITH PASSWORD 'postgres';" || die
- createdb -h "${T}" -U postgres _test_db || die
-
- distutils-r1_src_test
-
- pg_ctl -w -D "${db}" stop || die
-}
diff --git a/dev-python/pgspecial/pgspecial-2.1.2.ebuild b/dev-python/pgspecial/pgspecial-2.1.2.ebuild
index 899d00595aa4..160c438e2316 100644
--- a/dev-python/pgspecial/pgspecial-2.1.2.ebuild
+++ b/dev-python/pgspecial/pgspecial-2.1.2.ebuild
@@ -16,7 +16,7 @@ HOMEPAGE="
LICENSE="BSD MIT"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
+KEYWORDS="amd64 arm64 x86"
RDEPEND="
>=dev-python/click-4.1[${PYTHON_USEDEP}]