summaryrefslogtreecommitdiff
path: root/dev-python/pgspecial
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pgspecial')
-rw-r--r--dev-python/pgspecial/Manifest4
-rw-r--r--dev-python/pgspecial/pgspecial-2.1.2.ebuild60
-rw-r--r--dev-python/pgspecial/pgspecial-2.1.3.ebuild7
3 files changed, 6 insertions, 65 deletions
diff --git a/dev-python/pgspecial/Manifest b/dev-python/pgspecial/Manifest
index 370e98be8809..81614ae1cc85 100644
--- a/dev-python/pgspecial/Manifest
+++ b/dev-python/pgspecial/Manifest
@@ -1,5 +1,3 @@
-DIST pgspecial-2.1.2.tar.gz 51057 BLAKE2B d164555363e421f716fd9a03653fa8ef6628fc15b71a03acb040c321a20d03e4193725ca3a809b3d4b8710e62005ba9637f35789795d7b4e195f653527617436 SHA512 3ef15c96b8ae84c2c346f44607360aad4bd0abe6f2dfec421af1ca176178b19c64d55baece118600038e105cacb4b5f9b9c3eebbd1e816a9e7a78877d2cb604c
DIST pgspecial-2.1.3.tar.gz 51204 BLAKE2B 9dec06aba3c1389d0f2a772305dbde4218ecdcc298a325645e3c3869d9f7dc67d55c3b7dc724dbe4dde7b730ea90dd66028f71db3d5361a2618962d20fc97425 SHA512 67f7376cbad896a29e9ae76fd1f78b1e43069dc6a648eb0e68048f22420c606da437ef4b9f1b149a748161e12f061ccff2fd0682e7f2b9d2ac41003bc062b768
-EBUILD pgspecial-2.1.2.ebuild 1403 BLAKE2B 9a6a46d40c2c5a27420f529a45a81003f2d398d31fcdfb0355c97e48b91808d719b1ef8b1b29d5ec27a8f672f6ddcf3b07b9a85157ba35628bb9cbb8b882113b SHA512 c5ade7004b9536764bbe50c2cb3652271f35c99a2e0b8cf02eead2b089f0fd6e4423d837225702ae28b282efed27f9ed61a654d108612f7269b5b59a4f37a067
-EBUILD pgspecial-2.1.3.ebuild 1406 BLAKE2B 4387e50b50e86d7aecb3afeefbec47a934de06cce80b689b8582f8d03ba6bf25947b1495b1de65f3a0a324e2530bc89cf6644e5cf07cb0bf5160b0a7dec233ba SHA512 9f4b5fc61b13031431f35c673bb29b287fb16d3deec62608482a73d4c87e24651270568473f5c2d077e875307bb586659eab8880bbb32eaf967d794ff8bede6c
+EBUILD pgspecial-2.1.3.ebuild 1519 BLAKE2B cd5fd33f1284b5f3228e421f3ea5ba482afa63a2d1c1fc5347c5df11204d04a1470571b5cb6972132181c733315d0ed291c7d512fed36d7cb77565311c3e728a SHA512 5cdc509f288b3a17e86159ddc2b91e14c7cf6fd12c9e10dc2246974a34bb6fc584c49bb94a918f0a0a7da4a0381144a5f1724ed5b7a9331bbbb5620f446ed05e
MISC metadata.xml 542 BLAKE2B f7c36257d672854f57623ce68e09e17b8bc734e0a2afa70308ff3c3dfee23274750a8d98034527e14c757546eb78b84f170b9a4d180e02cf491301ae34127c79 SHA512 cb1eac0516db3ff5f32efb6adcf2c39e5479f7bb2a44f3d7c75f4e38e07812db21fd8e8af94e97c613b54606c2660317b5dbb0221c88cc926968404898f19602
diff --git a/dev-python/pgspecial/pgspecial-2.1.2.ebuild b/dev-python/pgspecial/pgspecial-2.1.2.ebuild
deleted file mode 100644
index 4fa8bed1bfce..000000000000
--- a/dev-python/pgspecial/pgspecial-2.1.2.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Python implementation of PostgreSQL meta commands"
-HOMEPAGE="
- https://github.com/dbcli/pgspecial/
- https://pypi.org/project/pgspecial/
-"
-
-LICENSE="BSD MIT"
-SLOT="0"
-KEYWORDS="amd64 arm64 x86"
-
-RDEPEND="
- >=dev-python/click-4.1[${PYTHON_USEDEP}]
- >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
- >=dev-python/psycopg-3.0.10:0[${PYTHON_USEDEP}]
- >=dev-python/sqlparse-0.1.19[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- >=dev-db/postgresql-8.1[server]
- )
-"
-
-distutils_enable_tests pytest
-
-DOCS=( License.txt README.rst changelog.rst )
-
-EPYTEST_DESELECT=(
- # assumes a very specific locale
- tests/test_specials.py::test_slash_l
- tests/test_specials.py::test_slash_l_pattern
- # change in postgres? *shrug*
- tests/test_specials.py::test_slash_d_view_verbose
- tests/test_specials.py::test_slash_dn
-)
-
-src_test() {
- local db=${T}/pgsql
-
- initdb --username=postgres -D "${db}" || die
- # TODO: random port
- pg_ctl -w -D "${db}" start \
- -o "-h '127.0.0.1' -p 5432 -k '${T}'" || die
- psql -h "${T}" -U postgres -d postgres \
- -c "ALTER ROLE postgres WITH PASSWORD 'postgres';" || die
- createdb -h "${T}" -U postgres _test_db || die
-
- distutils-r1_src_test
-
- pg_ctl -w -D "${db}" stop || die
-}
diff --git a/dev-python/pgspecial/pgspecial-2.1.3.ebuild b/dev-python/pgspecial/pgspecial-2.1.3.ebuild
index 0d092904d231..27e9bdd58e19 100644
--- a/dev-python/pgspecial/pgspecial-2.1.3.ebuild
+++ b/dev-python/pgspecial/pgspecial-2.1.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -16,7 +16,7 @@ HOMEPAGE="
LICENSE="BSD MIT"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
+KEYWORDS="amd64 arm64 x86"
RDEPEND="
>=dev-python/click-4.1[${PYTHON_USEDEP}]
@@ -41,6 +41,9 @@ EPYTEST_DESELECT=(
# change in postgres? *shrug*
tests/test_specials.py::test_slash_d_view_verbose
tests/test_specials.py::test_slash_dn
+ # fails with postgresql:17
+ tests/test_specials.py::test_slash_ddp
+ tests/test_specials.py::test_slash_ddp_pattern
)
src_test() {