summaryrefslogtreecommitdiff
path: root/dev-python/pgspecial/pgspecial-1.11.10.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pgspecial/pgspecial-1.11.10.ebuild')
-rw-r--r--dev-python/pgspecial/pgspecial-1.11.10.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pgspecial/pgspecial-1.11.10.ebuild b/dev-python/pgspecial/pgspecial-1.11.10.ebuild
new file mode 100644
index 000000000000..1f8952ae4e42
--- /dev/null
+++ b/dev-python/pgspecial/pgspecial-1.11.10.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of PostgreSQL meta commands"
+HOMEPAGE="https://github.com/dbcli/pgspecial"
+SRC_URI="https://github.com/dbcli/pgspecial/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/click-4.1[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2.7.4[${PYTHON_USEDEP}]
+ >=dev-python/sqlparse-0.1.19[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+DOCS=( License.txt README.rst changelog.rst )