summaryrefslogtreecommitdiff
path: root/dev-python/pep8/pep8-1.7.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pep8/pep8-1.7.0.ebuild')
-rw-r--r--dev-python/pep8/pep8-1.7.0.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/pep8/pep8-1.7.0.ebuild b/dev-python/pep8/pep8-1.7.0.ebuild
deleted file mode 100644
index 17171746b219..000000000000
--- a/dev-python/pep8/pep8-1.7.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python style guide checker"
-HOMEPAGE="https://github.com/PyCQA/pep8 https://pypi.org/project/pep8/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- PYTHONPATH="${S}" "${PYTHON}" pep8.py -v --statistics pep8.py || die
- PYTHONPATH="${S}" "${PYTHON}" pep8.py -v --testsuite=testsuite || die
- PYTHONPATH="${S}" "${PYTHON}" pep8.py --doctest -v || die
- esetup.py test
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}