summaryrefslogtreecommitdiff
path: root/dev-python/pendulum/pendulum-2.1.2-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pendulum/pendulum-2.1.2-r2.ebuild')
-rw-r--r--dev-python/pendulum/pendulum-2.1.2-r2.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-python/pendulum/pendulum-2.1.2-r2.ebuild b/dev-python/pendulum/pendulum-2.1.2-r2.ebuild
index 92ab23647da8..dcc1239b8504 100644
--- a/dev-python/pendulum/pendulum-2.1.2-r2.ebuild
+++ b/dev-python/pendulum/pendulum-2.1.2-r2.ebuild
@@ -5,7 +5,7 @@ EAPI=7
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
@@ -39,4 +39,10 @@ BDEPEND="
)
"
+EPYTEST_DESELECT=(
+ # sigh
+ tests/datetime/test_behavior.py::test_proper_dst
+ tests/tz/test_timezone.py::test_dst
+)
+
distutils_enable_tests pytest