summaryrefslogtreecommitdiff
path: root/dev-python/pecan/pecan-1.4.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pecan/pecan-1.4.1.ebuild')
-rw-r--r--dev-python/pecan/pecan-1.4.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pecan/pecan-1.4.1.ebuild b/dev-python/pecan/pecan-1.4.1.ebuild
new file mode 100644
index 000000000000..c736d6979670
--- /dev/null
+++ b/dev-python/pecan/pecan-1.4.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A WSGI object-dispatching web framework, lean, fast, with few dependencies"
+HOMEPAGE="https://pypi.org/project/pecan/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/webob-1.4[${PYTHON_USEDEP}]
+ >=dev-python/mako-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/webtest-1.3.1[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/logutils-0.3.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest