summaryrefslogtreecommitdiff
path: root/dev-python/pebble/pebble-4.6.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pebble/pebble-4.6.2.ebuild')
-rw-r--r--dev-python/pebble/pebble-4.6.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/pebble/pebble-4.6.2.ebuild b/dev-python/pebble/pebble-4.6.2.ebuild
new file mode 100644
index 000000000000..a56e138d22ff
--- /dev/null
+++ b/dev-python/pebble/pebble-4.6.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P=${P^}
+DESCRIPTION="Threading and multiprocessing eye-candy"
+HOMEPAGE="
+ https://pypi.org/project/Pebble/
+ https://pebble.readthedocs.io/
+ https://github.com/noxdafox/pebble"
+SRC_URI="mirror://pypi/${MY_P::1}/${PN^}/${MY_P}.tar.gz"
+S=${WORKDIR}/${P^}
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+distutils_enable_tests pytest