summaryrefslogtreecommitdiff
path: root/dev-python/pdm
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pdm')
-rw-r--r--dev-python/pdm/Manifest2
-rw-r--r--dev-python/pdm/pdm-2.22.0.ebuild132
2 files changed, 134 insertions, 0 deletions
diff --git a/dev-python/pdm/Manifest b/dev-python/pdm/Manifest
index 865b9000e454..032c2f20de5c 100644
--- a/dev-python/pdm/Manifest
+++ b/dev-python/pdm/Manifest
@@ -1,5 +1,7 @@
DIST pdm-2.20.1.tar.gz 2642376 BLAKE2B d24d889d75b06deb7595a7a0691ba21e9af15013372481147ddf1c6a19a13bb398af786cbc38877b29380f162a7923848aaf9d9b6f258dcd22ad80a96ad96ab8 SHA512 f9a164c521f943a89c8eb4792d249b06114b26e5c87022feb0d1bc24ca8ef56085da07e8b0dd9033b3c6e7d0e0ff1d3cb52bf8a69a2ef1e211cdb3c29eeb24b8
DIST pdm-2.21.0.tar.gz 2643561 BLAKE2B 3fc921c5863749c762163b290a4c9db8593145f509309dfe3437444e509e11c4727510d862e5f8676755191429c0b5cd73afd98104056497a3095acb6d0ee488 SHA512 2e83eab81d85c91249841add97a1d985ac91a0fba42b7b695a23afa785d67c04879a2513a686243fd68e5eec642175b97ef7e36fccbe8d8a160a6d42b8c5318b
+DIST pdm-2.22.0.tar.gz 2645896 BLAKE2B 96cb47299ac52f374bc3e6e22f28d79b3cd0536055292e68f2f76c2f6ef855abbc4840c1a500c43dca02d10fa964bf3595512536855792175817ddf0d4f9ed14 SHA512 5f27a070fce875b3fd9af30ee9cfab1c31f4310bb9e299a11d00beba77e02dfd6346496ac385aaf5ae3f43b96cae91ef97f46766071696834c8a8714fff5bb4f
EBUILD pdm-2.20.1.ebuild 5339 BLAKE2B ae16196aa6329fc47283e662e871df653bd429349f2b95e5f91fa38670fe0a59fd31dc3bb300a1128bdbf854b6a98b5dfc608e1fc35c0582234f3a379be0f547 SHA512 efcd611ce6a02d057bce1904b6c10f528d4f3de8775b0b82e71fd09fa5f263a625691ddbe51d157776797770af32b3fc0fabad6dcfa4e500114a43b3f7eaec90
EBUILD pdm-2.21.0.ebuild 5339 BLAKE2B ae16196aa6329fc47283e662e871df653bd429349f2b95e5f91fa38670fe0a59fd31dc3bb300a1128bdbf854b6a98b5dfc608e1fc35c0582234f3a379be0f547 SHA512 efcd611ce6a02d057bce1904b6c10f528d4f3de8775b0b82e71fd09fa5f263a625691ddbe51d157776797770af32b3fc0fabad6dcfa4e500114a43b3f7eaec90
+EBUILD pdm-2.22.0.ebuild 5583 BLAKE2B 7b5c65708ad93d2ed5509f17bdb65a75dc156927422b6709965b6b65e643ab32d72d41196442d263f98b90ee7e2baf7db075081af545c889c31a4ec1806f967a SHA512 e6564dd540154eb9694ecd1b67836b281c7f8476d3836fec8124a430921589ed773068e4b5123211f494e98c6c43777dba28aeb5e48a78a3595d9509a44ae25d
MISC metadata.xml 474 BLAKE2B c1471e124a955920e30f73dfa43a87999c30c2bb9615590f601befcc07f7d939ec68908e67c7345fca4cb0f0524d33507aeac9936fa30d449d1dde17094048d3 SHA512 a07256061dda5a8cf8b0e15205ac36651a4e5b594fdedbfe16d1d3264e1ac42847d1dc222d2857232ac5206d67feda432751695d85d0c4c7b03fd7228db8b1ab
diff --git a/dev-python/pdm/pdm-2.22.0.ebuild b/dev-python/pdm/pdm-2.22.0.ebuild
new file mode 100644
index 000000000000..061b5361c485
--- /dev/null
+++ b/dev-python/pdm/pdm-2.22.0.ebuild
@@ -0,0 +1,132 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python package and dependency manager supporting the latest PEP standards"
+HOMEPAGE="
+ https://pdm-project.org/
+ https://github.com/pdm-project/pdm/
+ https://pypi.org/project/pdm/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-python/certifi[${PYTHON_USEDEP}]
+ >=dev-python/dep-logic-0.4.4[${PYTHON_USEDEP}]
+ <dev-python/findpython-1[${PYTHON_USEDEP}]
+ >=dev-python/findpython-0.6.0[${PYTHON_USEDEP}]
+ dev-python/blinker[${PYTHON_USEDEP}]
+ dev-python/filelock[${PYTHON_USEDEP}]
+ >=dev-python/hishel-0.0.32[${PYTHON_USEDEP}]
+ >=dev-python/httpcore-1.0.6[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/installer[${PYTHON_USEDEP}]
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pbs-installer-2024.4.18[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
+ dev-python/pyproject-hooks[${PYTHON_USEDEP}]
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+ >=dev-python/resolvelib-1.1[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ dev-python/shellingham[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ >=dev-python/truststore-0.9[${PYTHON_USEDEP}]
+ >=dev-python/unearth-0.17.0[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ dev-python/uv
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # unpin deps
+ sed -i -e 's:,<[0-9.a]*::' pyproject.toml || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ 'tests/cli/test_build.py::test_build_with_no_isolation[False]'
+ tests/test_project.py::test_access_index_with_auth
+ "tests/test_project.py::test_find_interpreters_with_PDM_IGNORE_ACTIVE_VENV[True]"
+ tests/cli/test_others.py::test_build_distributions
+ 'tests/models/test_candidates.py::test_expand_project_root_in_url[demo @ file:///${PROJECT_ROOT}/tests/fixtures/artifacts/demo-0.0.1.tar.gz]'
+ 'tests/models/test_candidates.py::test_expand_project_root_in_url[-e file:///${PROJECT_ROOT}/tests/fixtures/projects/demo-#-with-hash#egg=demo]'
+ tests/models/test_candidates.py::test_find_candidates_from_find_links
+ tests/cli/test_build.py::test_build_single_module
+ tests/cli/test_build.py::test_build_single_module_with_readme
+ tests/cli/test_build.py::test_build_package
+ tests/cli/test_build.py::test_build_src_package
+ tests/cli/test_build.py::test_build_package_include
+ tests/cli/test_build.py::test_build_src_package_by_include
+ tests/cli/test_build.py::test_build_with_config_settings
+ tests/cli/test_build.py::test_cli_build_with_config_settings
+ tests/cli/test_build.py::test_build_ignoring_pip_environment
+ tests/cli/test_others.py::test_show_self_package
+ tests/cli/test_publish.py::test_publish_and_build_in_one_run
+ "tests/cli/test_hooks.py::test_hooks[build]"
+ "tests/cli/test_hooks.py::test_hooks[publish]"
+ "tests/cli/test_hooks.py::test_skip_option_from_signal[build-pre_build]"
+ "tests/cli/test_hooks.py::test_skip_option_from_signal[build-post_build]"
+ "tests/cli/test_hooks.py::test_skip_option_from_signal[publish-pre_publish]"
+ "tests/cli/test_hooks.py::test_skip_option_from_signal[publish-pre_build]"
+ "tests/cli/test_hooks.py::test_skip_option_from_signal[publish-post_build]"
+ "tests/cli/test_hooks.py::test_skip_option_from_signal[publish-post_publish]"
+ "tests/cli/test_hooks.py::test_skip_all_option_from_signal[:all-build]"
+ "tests/cli/test_hooks.py::test_skip_all_option_from_signal[:all-publish]"
+ "tests/cli/test_hooks.py::test_skip_all_option_from_signal[:pre,:post-build]"
+ "tests/cli/test_hooks.py::test_skip_all_option_from_signal[:pre,:post-publish]"
+ "tests/cli/test_hooks.py::test_skip_pre_post_option_from_signal[pre-build]"
+ "tests/cli/test_hooks.py::test_skip_pre_post_option_from_signal[pre-publish]"
+ "tests/cli/test_hooks.py::test_skip_pre_post_option_from_signal[post-build]"
+ "tests/cli/test_hooks.py::test_skip_pre_post_option_from_signal[post-publish]"
+ "tests/cli/test_venv.py::test_conda_backend_create[True]"
+ "tests/cli/test_venv.py::test_conda_backend_create[False]"
+ tests/cli/test_lock.py::test_lock_all_with_excluded_groups
+ 'tests/resolver/test_resolve.py::test_resolve_local_artifacts[sdist]'
+ 'tests/resolver/test_resolve.py::test_resolve_two_extras_from_the_same_package'
+ 'tests/resolver/test_resolve.py::test_resolve_file_req_with_prerelease'
+ # hangs on interactive keyring prompts
+ tests/cli/test_config.py::test_repository_overwrite_default
+ tests/cli/test_config.py::test_hide_password_in_output_repository
+ tests/cli/test_config.py::test_hide_password_in_output_pypi
+ # junk output, sigh
+ tests/cli/test_others.py::test_info_command_json
+ # why does it try to use python 2.7?!
+ tests/cli/test_run.py::test_import_another_sitecustomize
+ # fails in tinderbox (bug #928964)
+ tests/test_project.py::test_project_packages_path
+ # i guess doesn't expect some dep to be present
+ tests/cli/test_build.py::test_build_with_no_isolation
+ )
+ [[ ${EPYTHON} != python3.10 ]] && EPYTEST_DESELECT+=(
+ # test seems hardcoded to 3.10
+ tests/test_project.py::test_project_packages_path
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -m "not network and not integration and not path" \
+ -p pytest_mock
+}