summaryrefslogtreecommitdiff
path: root/dev-python/pathlib2/pathlib2-2.3.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pathlib2/pathlib2-2.3.6.ebuild')
-rw-r--r--dev-python/pathlib2/pathlib2-2.3.6.ebuild31
1 files changed, 0 insertions, 31 deletions
diff --git a/dev-python/pathlib2/pathlib2-2.3.6.ebuild b/dev-python/pathlib2/pathlib2-2.3.6.ebuild
deleted file mode 100644
index ac123963984c..000000000000
--- a/dev-python/pathlib2/pathlib2-2.3.6.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( pypy3 python3_{8..9} )
-inherit distutils-r1
-
-DESCRIPTION="Fork of pathlib aiming to support the full stdlib Python API"
-HOMEPAGE="https://github.com/mcmtroffaes/pathlib2"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- ${RDEPEND}
- )
-"
-
-python_test() {
- "${EPYTHON}" tests/test_pathlib2.py -v ||
- die "tests failed with ${EPYTHON}"
-}