summaryrefslogtreecommitdiff
path: root/dev-python/pandas
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pandas')
-rw-r--r--dev-python/pandas/Manifest2
-rw-r--r--dev-python/pandas/files/pandas-2.1.1-which.patch12
-rw-r--r--dev-python/pandas/files/pandas-2.1.4-khash-dep.patch45
3 files changed, 0 insertions, 59 deletions
diff --git a/dev-python/pandas/Manifest b/dev-python/pandas/Manifest
index 63f47eef1369..d339d09c9079 100644
--- a/dev-python/pandas/Manifest
+++ b/dev-python/pandas/Manifest
@@ -1,5 +1,3 @@
-AUX pandas-2.1.1-which.patch 393 BLAKE2B d5a988d64efbe28a1d2e533eae2d2ac88a31a08697a112682af1fce07429fff7e7846fe378d6ab487cf8aebf30b357c022763f5fc578e6b90c7ced1ea1af97f1 SHA512 3e7895561aab74e3b3afbad46f371f97fa4ae7b7f8158961896114a9c62e9a4544e81f9cdce983029809a95cc23350bb9698d8b4acc92f34e3a5b844b7811edb
-AUX pandas-2.1.4-khash-dep.patch 1970 BLAKE2B fcd7b7426156de6061831a4a88c29a129cd2e860e8df33b44c4824a0dad448f088b0636cf5d9cfbc12894855580be990a30574e3a2374167240bf69239075dd5 SHA512 7a3a4bb61f4578b9a9b32134d5ff4c2772a387fcc77ec3c71a62bf9b33874c51a15e4f9097e922a1ac669cc150acd2d2f6ab086f759b838694105d5fd17a9a31
DIST pandas-2.2.1.tar.gz 4395256 BLAKE2B 7f66c2995699832930a626ff01b3b39bafa0bd19f41245b8b49bbf5a1b78663433060f4d94817498494b6cf66d38dde27da64e196c6400e50f30441d7e51991b SHA512 8e6af4793d8b77e5c86a22c88f999dba63b1cc1954f5148bdb8c9b1bfe4e7fc5004de7d0f035b2d651f56c44b28ba4b0bd304f9c9122426cc37fb97596e13746
DIST pandas-2.2.2.tar.gz 4398391 BLAKE2B 6b723d85c500abaca4d833e4fb329d9a495e3e8ae51c74632111b139ed38ca9e26087ba43ecc40d68f66613352dc140bb2f1b0cbb92915bb027548886072fc79 SHA512 85b006f96bd6400aeea2ec29df3557ea6c4bfee0a7aebb172547a43171dc0e7682d15f798081846a4f464559ab83f579cfe06d66d4b5c0cb0fb2975c2ef98f9c
EBUILD pandas-2.2.1-r1.ebuild 9146 BLAKE2B da78b2cf5dc66dd8a9178c3d2a3b1d1d45bdf14f7ee317c5171add626a45200d2506e11e667bd7b1d70d87cb63353af7e7fb322e8747373ca17732bba5e31095 SHA512 b729fdacc12baf37706fc16c74b215dc300446d25396948f8c779dac95493ede6313bf63432e23f92c34e40fd183bfd864ca1febbdfae378340fd7c8f3f4142a
diff --git a/dev-python/pandas/files/pandas-2.1.1-which.patch b/dev-python/pandas/files/pandas-2.1.1-which.patch
deleted file mode 100644
index 424c10af82ae..000000000000
--- a/dev-python/pandas/files/pandas-2.1.1-which.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/pandas/io/clipboard/__init__.py b/pandas/io/clipboard/__init__.py
-index c07f51d875..14d79fb367 100644
---- a/pandas/io/clipboard/__init__.py
-+++ b/pandas/io/clipboard/__init__.py
-@@ -87,6 +87,7 @@ else:
-
-
- def _executable_exists(name):
-+ return which(name)
- return (
- subprocess.call(
- [WHICH_CMD, name], stdout=subprocess.PIPE, stderr=subprocess.PIPE
diff --git a/dev-python/pandas/files/pandas-2.1.4-khash-dep.patch b/dev-python/pandas/files/pandas-2.1.4-khash-dep.patch
deleted file mode 100644
index f8bbff5fed37..000000000000
--- a/dev-python/pandas/files/pandas-2.1.4-khash-dep.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From e31a6865958442435ae9b31f312129c44f66eb5e Mon Sep 17 00:00:00 2001
-From: Ville Aikas <11279988+vaikas@users.noreply.github.com>
-Date: Mon, 6 Nov 2023 09:24:40 -0800
-Subject: [PATCH] Add missing dependencies for: _khash_primitive_helper
- (#55795)
-
-* Add missing dependencies for: _khash_primitive_helper
-
-Signed-off-by: Ville Aikas <vaikas@chainguard.dev>
-
-* source->dep change.
-
-Signed-off-by: Ville Aikas <vaikas@chainguard.dev>
-
-* Remove dep from arrays.
-
-Signed-off-by: Ville Aikas <vaikas@chainguard.dev>
-
----------
-
-Signed-off-by: Ville Aikas <vaikas@chainguard.dev>
----
- pandas/_libs/meson.build | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/pandas/_libs/meson.build b/pandas/_libs/meson.build
-index b4662d6bf8dd2..c27386743c6e9 100644
---- a/pandas/_libs/meson.build
-+++ b/pandas/_libs/meson.build
-@@ -61,12 +61,12 @@ subdir('tslibs')
- libs_sources = {
- # Dict of extension name -> dict of {sources, include_dirs, and deps}
- # numpy include dir is implicitly included
-- 'algos': {'sources': ['algos.pyx', _algos_common_helper, _algos_take_helper, _khash_primitive_helper]},
-+ 'algos': {'sources': ['algos.pyx', _algos_common_helper, _algos_take_helper], 'deps': _khash_primitive_helper_dep},
- 'arrays': {'sources': ['arrays.pyx']},
- 'groupby': {'sources': ['groupby.pyx']},
- 'hashing': {'sources': ['hashing.pyx']},
-- 'hashtable': {'sources': ['hashtable.pyx', _khash_primitive_helper, _hashtable_class_helper, _hashtable_func_helper]},
-- 'index': {'sources': ['index.pyx', _index_class_helper]},
-+ 'hashtable': {'sources': ['hashtable.pyx', _hashtable_class_helper, _hashtable_func_helper], 'deps': _khash_primitive_helper_dep},
-+ 'index': {'sources': ['index.pyx', _index_class_helper], 'deps': _khash_primitive_helper_dep},
- 'indexing': {'sources': ['indexing.pyx']},
- 'internals': {'sources': ['internals.pyx']},
- 'interval': {'sources': ['interval.pyx', _intervaltree_helper],