summaryrefslogtreecommitdiff
path: root/dev-python/paginate
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/paginate')
-rw-r--r--dev-python/paginate/Manifest2
-rw-r--r--dev-python/paginate/paginate-0.5.7.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/paginate/Manifest b/dev-python/paginate/Manifest
index 35c3a8af63dd..fe6c3477b79c 100644
--- a/dev-python/paginate/Manifest
+++ b/dev-python/paginate/Manifest
@@ -1,3 +1,5 @@
DIST paginate-0.5.6.gh.tar.gz 15567 BLAKE2B c5b60ad43c61a918c618668b345cae82e5e61516aa73130339830db8b8d1d49d271ed24bf9379c570ef8ae9de0844ff8e088820c7e128e1e6e77a03427c06596 SHA512 64d7d1a9952dc8ae5894113c381a9cdca5395477091d794774ed770f1e1dfb6a5d88a7bd07cc4fca0c0c8f708656261f3160b315af6f86ecc5b7f46e1d639150
+DIST paginate-0.5.7.gh.tar.gz 16751 BLAKE2B bc109607876b214572707cbfda25e35b57c80fc6947838ff31feab9299f3a51ad91df44dc5b5040583084a64609cb3156c9c344906f3b719cf55832a2bbe348d SHA512 f0e1957ff7b9177f052ae985e103b93acd55c9390bc06479926ccdc288343720214a02d2de46700caceb07d934d33baabdc364fc8cbd997a29fb433383892405
EBUILD paginate-0.5.6.ebuild 941 BLAKE2B 8d5795b3133eea8fa92511e9a051bedcb1f58d6783976686c32a5a10fe99af3a14926f9007c131c9338fa709bdb9afbdca1d0173fefd10acb1031b8a6818c7c0 SHA512 ab86bbbabac679d05d123c5e87a5c43ae6468830996d6d86426edac4e726f2113bbdea5e8841d2b4aa6afa31748f7bb866ed1a65cab02164641186ab76233525
+EBUILD paginate-0.5.7.ebuild 944 BLAKE2B b862fb8428c82e51301608599c3886b62f70a4ce290721ca08c5d5b4dbdb4166bb8b4b6108ccbab8dff0ded7098de677fe917eac0aa6824e37e66ea45d6099cd SHA512 4866e8789f74d7d7918caeccb60f902c9cb6bb134d43704ff95f39f904d226f372d4c525673e0dcdfb132a9c40af3a02fc5c69b436ba268083b93260d5e59a9f
MISC metadata.xml 369 BLAKE2B 19b0ed57cf4d77b7c7b5743db890ac9b4c9291770480ea34fc136ec9cd4c70a0bf7fa5adfd831714cfbe90bc6d2386c1ff6446ce7402d51675b2e23b3659fd6e SHA512 302d1f3ba21ecd4cc6ed7905f8b49e524d21aa32ae810d5b9124ec8a7ea2802fd79997afd573988679db1f246f193653ae34f2b275c27d30762002b66e55dcd5
diff --git a/dev-python/paginate/paginate-0.5.7.ebuild b/dev-python/paginate/paginate-0.5.7.ebuild
new file mode 100644
index 000000000000..e89c4cd893d9
--- /dev/null
+++ b/dev-python/paginate/paginate-0.5.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Divides large result sets into pages for easier browsing"
+HOMEPAGE="
+ https://github.com/Pylons/paginate/
+ https://pypi.org/project/paginate/
+"
+SRC_URI="
+ https://github.com/Pylons/paginate/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+
+ case ${EPYTHON} in
+ python3.13)
+ ;&
+ python3.12)
+ EPYTEST_DESELECT+=(
+ # these tests assume that dict is not sliceable
+ # https://github.com/Pylons/paginate/issues/19
+ tests/test_paginate.py::test_wrong_collection
+ tests/test_paginate.py::TestCollectionTypes::test_unsliceable_sequence3
+ )
+ ;;
+ esac
+
+ epytest
+}