summaryrefslogtreecommitdiff
path: root/dev-python/oslo-upgradecheck/oslo-upgradecheck-0.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/oslo-upgradecheck/oslo-upgradecheck-0.2.1.ebuild')
-rw-r--r--dev-python/oslo-upgradecheck/oslo-upgradecheck-0.2.1.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/oslo-upgradecheck/oslo-upgradecheck-0.2.1.ebuild b/dev-python/oslo-upgradecheck/oslo-upgradecheck-0.2.1.ebuild
deleted file mode 100644
index ff64429a1ec8..000000000000
--- a/dev-python/oslo-upgradecheck/oslo-upgradecheck-0.2.1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-MY_PN=${PN/-/.}
-
-DESCRIPTION="Oslo i18n library"
-HOMEPAGE="https://launchpad.net/oslo"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE=""
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
- >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
- >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
- <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
- sed -i '/^hacking/d' test-requirements.txt || die
- distutils-r1_python_prepare_all
-}