summaryrefslogtreecommitdiff
path: root/dev-python/oslo-config/oslo-config-6.11.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/oslo-config/oslo-config-6.11.2.ebuild')
-rw-r--r--dev-python/oslo-config/oslo-config-6.11.2.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/oslo-config/oslo-config-6.11.2.ebuild b/dev-python/oslo-config/oslo-config-6.11.2.ebuild
deleted file mode 100644
index 8bc82001771a..000000000000
--- a/dev-python/oslo-config/oslo-config-6.11.2.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-MY_PN=${PN/-/.}
-
-DESCRIPTION="Oslo Configuration API"
-HOMEPAGE="https://launchpad.net/oslo"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-CDEPEND=">=dev-python/pbr-1.3[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
-"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
- >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
- >=dev-python/rfc3986-1.2.0[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
- >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
- sed -i '/^hacking/d' test-requirements.txt || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- rm -rf .testrepository || die "could not remove '.testrepository' under ${EPTYHON}"
-
- testr init || die "testr init failed under ${EPYTHON}"
- testr run || die "testr run failed under ${EPYTHON}"
-}