summaryrefslogtreecommitdiff
path: root/dev-python/oslo-concurrency
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/oslo-concurrency')
-rw-r--r--dev-python/oslo-concurrency/Manifest2
-rw-r--r--dev-python/oslo-concurrency/oslo-concurrency-6.1.0.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/oslo-concurrency/Manifest b/dev-python/oslo-concurrency/Manifest
index 0dd0a68aabe1..10f0eeac0985 100644
--- a/dev-python/oslo-concurrency/Manifest
+++ b/dev-python/oslo-concurrency/Manifest
@@ -1,3 +1,5 @@
DIST oslo.concurrency-6.0.0.tar.gz 60373 BLAKE2B 24002c424894826f86d9fa7601d107ab04159ace9388944b615d4c1e35f54d5d8438b1a5021a3c3b0ef755d9b92382b9804fe8f7a84075feb7d7d523a4d1cbe9 SHA512 6a706e0590f6e29ab560e4133ffdb8dbd6c2cb2dc7cd16acd803ca93800a38223f57eec8c79698c9fe5bf47b1cdcbb89e1a98d3ea36f03a9ccee9da9ab39a0d9
+DIST oslo.concurrency-6.1.0.tar.gz 60320 BLAKE2B a1f4303b10e6e736395ee1597a35a26e7c959dc32895121e0576ddd4216b2edc5cd5383e7bedb776885f7d451e9232e08517b9b2bc92c0bfe8bef3c67541d3c7 SHA512 dfee864dae2f69d5e1ae32213bf09bffdd492131a04ba3df9ec9c9a793f2b1b6f4cae809977bf732bb310009116d762768adac4946afcfef49bd8dc993eee777
EBUILD oslo-concurrency-6.0.0.ebuild 1172 BLAKE2B aba5775b1240e626bdf3a464015c4562d7457ff1fd7c4f578fc5d85e102933fefba4c5bd96fef003be42268c01d832b425f56b1599472d0104d17150c1611578 SHA512 4c958ae825e8dbd4434d5d3ad030d17b08e70fe9f609c844b143dd229f415f4a49b68e482ea4103450c305fa3aaf1dfefbc2c71a4165b0504d674ad15daa1c5a
+EBUILD oslo-concurrency-6.1.0.ebuild 1175 BLAKE2B 5812994bf6b163b26c53df7c51225f7f2a52aaad5c9994533650949c0d715dff6954759a08d406d25a786b9a6eb6aead042424d1a80aa722ac43bd1338261f34 SHA512 d32f585c32e54093fccf059dd4488519f03fba716f83389109eb545c29a09fa4d94ea6477bccdc212425cd8c6f027326105ca20153cad84f45b09fb4933f69c4
MISC metadata.xml 423 BLAKE2B 965b9f3a9b25cd0f93f13bc12af982b8435e946c1317b6c3a013d016ac6ac3df39f94e1a69f6ef28355459cc5d59fa32c2004727e6772696dab755aee6ad46f4 SHA512 ffc8e1547e6f8356071744a4cf2d5f88d02f2a34322857245c68057699f0b87ea351a7821682ab3d72b777260c8887524467a201fe931787fa1b2ad67eb022a3
diff --git a/dev-python/oslo-concurrency/oslo-concurrency-6.1.0.ebuild b/dev-python/oslo-concurrency/oslo-concurrency-6.1.0.ebuild
new file mode 100644
index 000000000000..ee03a2c3008d
--- /dev/null
+++ b/dev-python/oslo-concurrency/oslo-concurrency-6.1.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Oslo Concurrency library"
+HOMEPAGE="
+ https://opendev.org/openstack/oslo.concurrency/
+ https://github.com/openstack/oslo.concurrency/
+ https://pypi.org/project/oslo.concurrency/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/fasteners-0.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # fails, then hangs
+ rm oslo_concurrency/tests/unit/test_lockutils_eventlet.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ eunittest
+}