summaryrefslogtreecommitdiff
path: root/dev-python/oslo-cache
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/oslo-cache')
-rw-r--r--dev-python/oslo-cache/Manifest2
-rw-r--r--dev-python/oslo-cache/oslo-cache-2.3.0.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/oslo-cache/Manifest b/dev-python/oslo-cache/Manifest
index b6f8223d514f..9c2d12ef6356 100644
--- a/dev-python/oslo-cache/Manifest
+++ b/dev-python/oslo-cache/Manifest
@@ -1,3 +1,5 @@
DIST oslo-cache-1.33.3.tar.gz 56098 BLAKE2B b3d2ab549a2b2066ffdfc5d9b680da35501818719a8c6f460be1520c2d6342f1c41f0f1aa20ffdcc45958e83e242515a3ec8bf69ce1273ab47a8a26e648069c8 SHA512 7edc1d8ceb00f2989093ec1809120f2aa552de2d5ce6176c9af56278040d652fc0d627e0f7f427b9bacaaa24cec7b0fe24568316d90a4e52054357bc9b9e30e2
+DIST oslo-cache-2.3.0.tar.gz 57209 BLAKE2B aa34c4deb0206c86181e629b1ccedaa3b0b7a503f4648b9ffb23dcba84c98658017a720701176776652a2a58447c54662314dd4853ec6ccf6c2acebb4b559325 SHA512 c3ad9c326fa71985d4546bd20bcb8aa9508808c8eae2a9e3dac1c014d148bfa8f5a847eb2ca8d1a204cce07b6d640f9541491dd41c7c6169e993e408786358af
EBUILD oslo-cache-1.33.3.ebuild 1064 BLAKE2B 753592d05bf39a8ac6ec16c056bddedb5e99b007d57679d277dd74e598531c8388fa19f421e8c5a537cd4269e5e448f2162e6f15ea02abb01135524580e66c80 SHA512 90195588142d161bfa928a5690ac37d0fd0b125c0f44448289251e12116357e9f1bb3fa232228022a8b348d297e338aff14abc3a736f450c137a073acb9b3d90
+EBUILD oslo-cache-2.3.0.ebuild 1023 BLAKE2B fc25169df8bb81be966a7e8776bd2d3d2d690f72ab56133841ae6937f1542fba589a60d054cf974d6072aa5f59180655b5da992d1cf9406243029cb81d7e497d SHA512 4f3c9aea97dcb20064430c073553f4d927d01b6dff2895e33159f5a7eeba73ffe51fd0bd6d541aab1ca443271878acca6ad82eb50b8c0471ec269a98b6bce242
MISC metadata.xml 457 BLAKE2B 09e44ecf9952f5bfd930616506874014a267d8622daf6c22b3da4856d9f4bbedcb3e4e72285972da026f310c47973c0bb70c222292caf877d4f9ab6d5166955a SHA512 f98547e9de8c502afabf7c53409df90ec687159b5160c8ff2166acff4d6bce0fe69c8eec78d50f52919cd75733f44f82dea5f9cde362d22ed69200d332b9d6b7
diff --git a/dev-python/oslo-cache/oslo-cache-2.3.0.ebuild b/dev-python/oslo-cache/oslo-cache-2.3.0.ebuild
new file mode 100644
index 000000000000..617334205e5a
--- /dev/null
+++ b/dev-python/oslo-cache/oslo-cache-2.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Oslo Caching around dogpile.cache"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/dogpile-cache-0.6.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.30.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.31.0[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+)
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}