summaryrefslogtreecommitdiff
path: root/dev-python/optcomplete
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/optcomplete')
-rw-r--r--dev-python/optcomplete/Manifest3
-rw-r--r--dev-python/optcomplete/metadata.xml20
-rw-r--r--dev-python/optcomplete/optcomplete-1.2-r1.ebuild25
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/optcomplete/Manifest b/dev-python/optcomplete/Manifest
new file mode 100644
index 000000000000..57ad5ed64534
--- /dev/null
+++ b/dev-python/optcomplete/Manifest
@@ -0,0 +1,3 @@
+DIST optcomplete-1.2.tar.bz2 15358 BLAKE2B 57f6f22dff4523619bfd61edd2cced917f17713c23123a5ecb8aa338c053540aa445d70de8095eb63571e69aebf367fdc8082046336d87d97dee2648b94c0d59 SHA512 2b2a902755eae0da0d362e6c504bd007fd13309ac515e6b68d6b2d177648645b7bd9c73d172c5eb2d0473caf261d8d60583a8f83779c901d50c304c03811e7ea
+EBUILD optcomplete-1.2-r1.ebuild 613 BLAKE2B bcf645f6e322a7d0d8d4bacdf935ba247269140b015544212fd54c68b7348544fd9f0b228991e86b5e1146cf9e1c5c421ef6d37d7f2236c2dd7bbabb3302410c SHA512 bf82c34c50ea430fe0e108c9517192bdaee53b5a30d48bb454502ef3efddb056ede63d84aeb38c9e59597b758c534c4b94aa1b384f39f972a429ac6336fd7694
+MISC metadata.xml 892 BLAKE2B 93a970370e8ec0d6f67a5fde2d72e1bd8dfaf33bdb6c4c1646dbd9ff4aa49509f900b28e51574de62f06ef28acc061139ec15502243f7411f010734542876c54 SHA512 5ccd2ef13a6d0a76497e3e1cdf15f819ea456271a269dfed87681111c5fb590e48669291054978aefc83eaa2332d8eb08532278d990a483b61883abb1a4ca4e4
diff --git a/dev-python/optcomplete/metadata.xml b/dev-python/optcomplete/metadata.xml
new file mode 100644
index 000000000000..3620338c02cf
--- /dev/null
+++ b/dev-python/optcomplete/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ This Python module aims at providing almost automatically shell completion
+ for any Python program that already uses the optparse module.
+
+ This module aims at placing the shell completion routine and the option
+ parsing code in a single location: in the program itself.
+
+ The logic is that since a program already knows about its options, and in
+ Python we have a standard module to specify them programmatically since
+ Python-2.3 (optparse), the program itself is in the best position to suggest
+ completions for an incomplete command-line to a shell that invokes it.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/optcomplete/optcomplete-1.2-r1.ebuild b/dev-python/optcomplete/optcomplete-1.2-r1.ebuild
new file mode 100644
index 000000000000..4c8787527dee
--- /dev/null
+++ b/dev-python/optcomplete/optcomplete-1.2-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Shell completion self-generator for Python"
+HOMEPAGE="http://furius.ca/optcomplete/ https://pypi.org/project/optcomplete/"
+SRC_URI="http://furius.ca/downloads/${PN}/releases/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-linux"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND=""
+
+python_install_all() {
+ use examples && local EXAMPLES=( bin/. )
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}