summaryrefslogtreecommitdiff
path: root/dev-python/openapi3
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/openapi3')
-rw-r--r--dev-python/openapi3/Manifest2
-rw-r--r--dev-python/openapi3/openapi3-1.8.2.ebuild11
2 files changed, 6 insertions, 7 deletions
diff --git a/dev-python/openapi3/Manifest b/dev-python/openapi3/Manifest
index 15b0f277dd34..d85af3fcc750 100644
--- a/dev-python/openapi3/Manifest
+++ b/dev-python/openapi3/Manifest
@@ -1,3 +1,3 @@
DIST openapi3-1.8.2.gh.tar.gz 41402 BLAKE2B a22af8ce1d1c94f3dd2b5f1871222c8c2ec902e9f8b5b065a9a3dd8143ed361df4b26438215e88ac416b6012b015a38c9709b9ed290aaf5cfdaff5b2d1d439f7 SHA512 5555ef0495f7d459fabef98c56da4b1b9d758aa06c4dc83adf1388c044dd0f6b09b933e105ef8665737359fbf98b9699ca2d7127ead2aa86e3f99682b29dbf1e
-EBUILD openapi3-1.8.2.ebuild 707 BLAKE2B 570103899104f15a36b45fc313a97ebd17ac598a3c1da7477f48ae759a6b5dfd1ea406d235269e715661b76f50f6cf7f5ef1c76d93f6ec2606c64f8811f02703 SHA512 77891da3251986e80db97eba7f6939dd61b080d9406837cc982cdfbb0b97fb5bf3b8fe426b260c744b2b6ff91c55a183151ffab1358013ac60d9a30cc94b30b2
+EBUILD openapi3-1.8.2.ebuild 691 BLAKE2B 791681dd04d83616c005cbd1ffd503fca263354014617ef3eefcc0393cb8114c886ea13919e97a72fc04b5c24ebb7b1282c825987c193e0a4afc3762ff8b5233 SHA512 292cfae99101daf660d667c5d9e64521715bf602a85b85910c3731a2dacd21087503e00ebf483945e98343dc60816ff7552b49ea9f93e62aca276b869ec29e07
MISC metadata.xml 344 BLAKE2B 14267f2fd846f243d2e3be1e21758a88efb8d57e654bca17a06a8b5fa7d8b80826049434ca94761ed504a7006f6dd0348d29c843f323d7ca4b0a1da26997c6b7 SHA512 3d3744a378a32f5037a322f3dacddf33ac638f17738b8588ccf5252a83ab7f60efac35890aaf1b57c888e7a725baa32bffaa81bb551f061fd7dcfd714b8df080
diff --git a/dev-python/openapi3/openapi3-1.8.2.ebuild b/dev-python/openapi3/openapi3-1.8.2.ebuild
index 77cb4b50a85a..7a93d407de51 100644
--- a/dev-python/openapi3/openapi3-1.8.2.ebuild
+++ b/dev-python/openapi3/openapi3-1.8.2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 2023 Gentoo Authors
+# Copyright 2023-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1
@@ -26,8 +26,7 @@ RDEPEND="
distutils_enable_tests pytest
-python_test() {
+EPYTEST_IGNORE=(
# the fastapi test is broken for fastapi 0.94+
- rm -f tests/fastapi_test.py || die
- epytest
-}
+ tests/fastapi_test.py
+)