summaryrefslogtreecommitdiff
path: root/dev-python/oauthlib/oauthlib-1.0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/oauthlib/oauthlib-1.0.3.ebuild')
-rw-r--r--dev-python/oauthlib/oauthlib-1.0.3.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/oauthlib/oauthlib-1.0.3.ebuild b/dev-python/oauthlib/oauthlib-1.0.3.ebuild
deleted file mode 100644
index f8e03aec186c..000000000000
--- a/dev-python/oauthlib/oauthlib-1.0.3.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
-
-inherit distutils-r1
-
-DESCRIPTION="Spec-compliant and thorough implementation of the OAuth request-signing logic"
-HOMEPAGE="https://github.com/idan/oauthlib https://pypi.org/project/oauthlib/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="test"
-
-# optional extras hard set as RDEPs. See setup.py
-RDEPEND="
- dev-python/pycrypto[${PYTHON_USEDEP}]
- >=dev-python/pyjwt-1.0.0[${PYTHON_USEDEP}]
- dev-python/blinker[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- "
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' python2_7)
- $(python_gen_cond_dep 'dev-python/unittest2[${PYTHON_USEDEP}]' python2_7) )
- "
-
-python_test() {
- nosetests || die "tests failed under ${EPYTHON}"
-}