summaryrefslogtreecommitdiff
path: root/dev-python/numpydoc
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/numpydoc')
-rw-r--r--dev-python/numpydoc/Manifest2
-rw-r--r--dev-python/numpydoc/numpydoc-1.7.0.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/numpydoc/Manifest b/dev-python/numpydoc/Manifest
index 4424884ca58b..fe3dc7eaf6e3 100644
--- a/dev-python/numpydoc/Manifest
+++ b/dev-python/numpydoc/Manifest
@@ -1,4 +1,6 @@
AUX numpydoc-1.6.0-py3.12-flt-depr-warn.patch 1790 BLAKE2B eb725720c4665da47d2596bf508e141b9100faab54babc56e5a2937acf2a8a889f7c37712417759c162bb8b6d1e4554d31ba888e297436d763429a937caae5d1 SHA512 76e766965ad482311775b440fc1aa88079761a080e8f4aeff245c00a6bd4163dc30cbce58c85a15efa3fa8d77b59c1c3d27d6c4c403536a58c3c09fba005e16d
DIST numpydoc-1.6.0.gh.tar.gz 85296 BLAKE2B 839fb0062dc1b0b45dfbc855d50d21a3c23cf1e9fef82b8d44e9d4cc36127c32447ad4c6ee5aa500cd24fb6a304f95426be69406468e3059c068ca4b0ad5714f SHA512 3846f395d8603a21d97a6c0fc57f0ea69e908ff2f672673d336a1f4ff02f5cb3f9e76d1e1ad6d990478b121a327bcca8179c3db6b5215f36818e41e4597878fd
+DIST numpydoc-1.7.0.gh.tar.gz 87818 BLAKE2B b31e9478324bc45d78904c16330c9ed1513eca5668f20472faf9e2a36c0ed7eb03b18cf1c314180ec35716a26bd05357d5ef93025efbb8fb09c885a614ac7ea9 SHA512 0858d7eaafdd93d5a0894bb107b8238f75bd7cd34afa64fee38effcf4bebf9b4db957768143a46eec46023e69b53599a79b07a39640887f3a0471b5996022247
EBUILD numpydoc-1.6.0.ebuild 1270 BLAKE2B fa48c1e33bf9dff3c3dbd2d252a66470be59a2d474da5b2d89cbe33d0a54c805042f6a400176602c9da443c9dc0faee45763be50af75800f11e03308dd77630a SHA512 5c481484a1e045559c6f38a98ec1ce8b9eb77d8412e1e3682ab9e157d905bbcef652fb1dc36f7e8668a87f6fd514ab7a4d4e20f2cab267ba88c98140919090ed
+EBUILD numpydoc-1.7.0.ebuild 1213 BLAKE2B 425ac5ce1f169756d473e9c921d5232bb119f594611a9430c55a320242318e53c56d99ea4ea91964d59e0574870440328e77230d2d4f978b5c32be515b36631e SHA512 aace50c98373d591c102e43c55693f8432c4b286dd32ea66eeffc294ac445580f38e781a3960b1b04db162f192c2ed99a7524fe2554ef934d5f9dc34017f6eb6
MISC metadata.xml 403 BLAKE2B 437fdd3881a5ec60a83b3cb018e57c714a91030be9ab0032b8662e30b7bcd120ee3dd2015be561dd8a65a39833ef777e22f040a6e466c1b56a602a4ac33d4917 SHA512 833d00712cf7dfdc1080181301c03388a3c966436d2d9c9badb609cff66fa49035a6d001d60f205e1c2c49808eda7fad65abda8802f42f7ba36939b3691a8390
diff --git a/dev-python/numpydoc/numpydoc-1.7.0.ebuild b/dev-python/numpydoc/numpydoc-1.7.0.ebuild
new file mode 100644
index 000000000000..b59ac424a9a6
--- /dev/null
+++ b/dev-python/numpydoc/numpydoc-1.7.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension to support docstrings in Numpy format"
+HOMEPAGE="
+ https://numpydoc.readthedocs.io/en/latest/
+ https://github.com/numpy/numpydoc/
+ https://pypi.org/project/numpydoc/
+"
+SRC_URI="
+ https://github.com/numpy/numpydoc/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/sphinx-6[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8.10[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/matplotlib-3.2.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # these require Internet (intersphinx)
+ numpydoc/tests/test_full.py::test_MyClass
+ numpydoc/tests/test_full.py::test_my_function
+ # TODO
+ numpydoc/tests/test_validate.py::test_extract_ignore_validation_comments
+ )
+ epytest -o addopts= --pyargs numpydoc
+}