summaryrefslogtreecommitdiff
path: root/dev-python/numpy
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/numpy')
-rw-r--r--dev-python/numpy/Manifest1
-rw-r--r--dev-python/numpy/numpy-1.17.4-r2.ebuild139
2 files changed, 140 insertions, 0 deletions
diff --git a/dev-python/numpy/Manifest b/dev-python/numpy/Manifest
index 7a671f58da2e..342593084493 100644
--- a/dev-python/numpy/Manifest
+++ b/dev-python/numpy/Manifest
@@ -25,5 +25,6 @@ EBUILD numpy-1.15.4.ebuild 3914 BLAKE2B b1e4541facef34dc973bd1de3d7c9fc556116fa9
EBUILD numpy-1.16.1.ebuild 3934 BLAKE2B 35063ed7529f4cb757b7dc3aaf8c0009bc4e72aafb6723267ac582ccccffa2e2f079d3cd067a88c32f935de3622abb1875d7bdcf8417d125ad1750f2568b5b2a SHA512 db1c4337360dddbcba2a34eb1f282dabeb652f36a3f216332b2e6d6ea8058e16dea642ea5e6f583871436e7ffa75eae59cb1daec797a41a3097678b8554ca5be
EBUILD numpy-1.16.5.ebuild 4223 BLAKE2B e8de035eab95a811936542fc223d71fce1c3a98c01b6c4f6f064d0fecf231acf4e3d28dfe368c09a06a84f6e95eafc7bd30eedd4fab5d58afc1f97bc792996da SHA512 2d47d1a95f0e2a7677a4ac29ce44ba519fd620c732bce8a2df15cbbfc6d198a56187e837e19ee27bdd8ed6bf7bd4d04d3c67a78e09ec0b2d4da8e0d74df04d41
EBUILD numpy-1.17.4-r1.ebuild 4079 BLAKE2B 7a93dfea3a35b7e85e7d97d47d14e4b5931412226b52c2d1cc5f18c075f5c6fed2f0612db6d82f484482382558fbc67fda1cc991f640c1c8a04d8cb71588b84f SHA512 2f4db1cea02f6094bedc19fcfea6d0a5390efd3d71e763740a1663d47c8316487d82cb4233e428e831266fa5e88d46441a6d097ef0796b08e6de6d4e9e999efe
+EBUILD numpy-1.17.4-r2.ebuild 3624 BLAKE2B 903d92b51a841916dd84edf5be6d13d5229c953bbe55067dd265a3ceb40dae50d8bdb3b0b26fc49863296c23a106a1e36687ce80650c0bee26006156bd470f98 SHA512 3d72c6a20b64892cdbe7e918825eaf2bfb2ee952d102e9f6dacfd2904e14188b1b3870fe4bfee63aa038c23c5222532f2e96dff1d2686b3e7d156294057616e9
EBUILD numpy-1.17.4.ebuild 4230 BLAKE2B 8ef305e01f0217df28459560322e08c13fb14f9447b094f65627f129f40cde81dd4ab9932226f2d9f1f1b610d0baa785028ed36487dc7e3e500eb8e666a00ffa SHA512 95dc8135ec99d8427e71f4722d7afdcbff4a6dd85f06b038ba1e6da488121d0c1d738a13b20dee3a0815ba9c749c4f90d641aca83d1f9bbe54190931837ce244
MISC metadata.xml 876 BLAKE2B 5e257d6ea3c59c5819d854db7b7db3ebff53b5c87b5ce9348786085f09db12aa6fc8fa86393b9e6c06760ac0d9f36a52fdfb1865c9d1d9ad5526d74d3d53e8b1 SHA512 d35d0954ff8f21e370edeab3ce3e5ab501bf216c93399e807ede6f1910ba0ea41359425bf894d813a39442fb92a724fe83ec8a5c64e6bd97de9422f67700d549
diff --git a/dev-python/numpy/numpy-1.17.4-r2.ebuild b/dev-python/numpy/numpy-1.17.4-r2.ebuild
new file mode 100644
index 000000000000..06da8045df13
--- /dev/null
+++ b/dev-python/numpy/numpy-1.17.4-r2.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="threads(+)"
+
+FORTRAN_NEEDED=lapack
+
+inherit distutils-r1 flag-o-matic fortran-2 multiprocessing toolchain-funcs
+
+DOC_PV="1.16.4"
+DESCRIPTION="Fast array and numerical python library"
+HOMEPAGE="https://www.numpy.org"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.zip
+ doc? (
+ https://numpy.org/doc/$(ver_cut 1-2 ${DOC_PV})/numpy-html.zip -> numpy-html-${DOC_PV}.zip
+ https://numpy.org/doc/$(ver_cut 1-2 ${DOC_PV})/numpy-ref.pdf -> numpy-ref-${DOC_PV}.pdf
+ https://numpy.org/doc/$(ver_cut 1-2 ${DOC_PV})/numpy-user.pdf -> numpy-user-${DOC_PV}.pdf
+ )"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc lapack test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ lapack? (
+ >=virtual/cblas-3.8
+ >=virtual/lapack-3.8
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ lapack? ( virtual/pkgconfig )
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.17.4-no-hardcode-blasv2.patch
+)
+
+src_unpack() {
+ default
+ if use doc; then
+ unzip -qo "${DISTDIR}"/numpy-html-${DOC_PV}.zip -d html || die
+ fi
+}
+
+python_prepare_all() {
+ if use lapack; then
+ local incdir="${EPREFIX}"/usr/include
+ local libdir="${EPREFIX}"/usr/$(get_libdir)
+ cat >> site.cfg <<-EOF || die
+ [blas]
+ include_dirs = ${incdir}
+ library_dirs = ${libdir}
+ blas_libs = cblas,blas
+ [lapack]
+ library_dirs = ${libdir}
+ lapack_libs = lapack
+ EOF
+ else
+ export {ATLAS,PTATLAS,BLAS,LAPACK,MKL}=None
+ fi
+
+ export CC="$(tc-getCC) ${CFLAGS}"
+
+ append-flags -fno-strict-aliasing
+
+ # See progress in http://projects.scipy.org/scipy/numpy/ticket/573
+ # with the subtle difference that we don't want to break Darwin where
+ # -shared is not a valid linker argument
+ if [[ ${CHOST} != *-darwin* ]]; then
+ append-ldflags -shared
+ fi
+
+ # only one fortran to link with:
+ # linking with cblas and lapack library will force
+ # autodetecting and linking to all available fortran compilers
+ append-fflags -fPIC
+ if use lapack; then
+ NUMPY_FCONFIG="config_fc --noopt --noarch"
+ # workaround bug 335908
+ [[ $(tc-getFC) == *gfortran* ]] && NUMPY_FCONFIG+=" --fcompiler=gnu95"
+ fi
+
+ # don't version f2py, we will handle it.
+ sed -i -e '/f2py_exe/s: + os\.path.*$::' numpy/f2py/setup.py || die
+
+ # disable fuzzed tests
+ find numpy/*/tests -name '*.py' -exec sed -i \
+ -e 's:def \(.*_fuzz\):def _\1:' {} + || die
+ # very memory- and disk-hungry
+ sed -i -e 's:test_large_zip:_&:' numpy/lib/tests/test_io.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ export MAKEOPTS=-j1 #660754
+
+ local python_makeopts_jobs=""
+ python_is_python3 || python_makeopts_jobs="-j $(makeopts_jobs)"
+ distutils-r1_python_compile \
+ ${python_makeopts_jobs} \
+ ${NUMPY_FCONFIG}
+}
+
+python_test() {
+ distutils_install_for_testing --single-version-externally-managed \
+ --record "${TMPDIR}/record.txt" ${NUMPY_FCONFIG}
+
+ cd "${TMPDIR}" || die
+
+ "${EPYTHON}" -c "
+import numpy, sys
+r = numpy.test(label='full', verbose=3)
+sys.exit(0 if r else 1)" || die "Tests fail with ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install ${NUMPY_FCONFIG}
+ python_optimize
+}
+
+python_install_all() {
+ local DOCS=( THANKS.txt )
+
+ if use doc; then
+ local HTML_DOCS=( "${WORKDIR}"/html/. )
+ DOCS+=( "${DISTDIR}"/${PN}-{user,ref}-${DOC_PV}.pdf )
+ fi
+
+ distutils-r1_python_install_all
+}