summaryrefslogtreecommitdiff
path: root/dev-python/numexpr
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/numexpr')
-rw-r--r--dev-python/numexpr/Manifest5
-rw-r--r--dev-python/numexpr/metadata.xml29
-rw-r--r--dev-python/numexpr/numexpr-2.6.1.ebuild58
-rw-r--r--dev-python/numexpr/numexpr-2.6.2.ebuild58
4 files changed, 0 insertions, 150 deletions
diff --git a/dev-python/numexpr/Manifest b/dev-python/numexpr/Manifest
deleted file mode 100644
index a1b5243218d1..000000000000
--- a/dev-python/numexpr/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-DIST numexpr-2.6.1.tar.gz 90819 BLAKE2B 833402388e184bd38c449bcda866f68858f486d5cf30aec29dc5e9827a34a40cb166128a8fb217f0ed1614e0b759cf2164e31cb2a16198ea3e6a216c9fe01853 SHA512 07c88b1788ecad2c59260e7a6a15dfc21d486462a8866091d157286e5ce3b5b77f5fdab401fd30e2a5e4880398af53641d557003497c7d3658421bfcff38c31c
-DIST numexpr-2.6.2.tar.gz 90970 BLAKE2B 85034d7d36bd921df289f817451e7b30071b9d448dc050e4f25afd13315921e3c10d61a41983cf106606e4efd91504e94ca7d8f01d80b230a9f717f41eb687ee SHA512 730e19e61987ecb00bfc3a65db043c88a1311046f2ea5f0a48c93d6a8d7576dbaa166b0b9b0f547e344b21b5c269be1b5aa2097e88aaac55219884c7ece55261
-EBUILD numexpr-2.6.1.ebuild 1385 BLAKE2B 1331948ae46b9d20c3122e5d779bc00db85bd11dfca73f63ca80d1fdf27f43c6fe2297dc0556d0bc0b0275516052608f07ebd6f323b95e89c40ae8781f63078d SHA512 dba9ff2f89c309efd420ef478a1fb8bd75036eeeb66d758c008ca5e8dc33d43f95886fb8883feeec7861108b8173f54b764852f1c5993e19f30d8cff9213e50a
-EBUILD numexpr-2.6.2.ebuild 1387 BLAKE2B 96400c41fd73d431b291d351bf6c57a711534ea5d0df22d091a5a4e5d19da1700e46c28c0c8a47f3dc1d6109cc6472384100c1e18b771ec5798f90392560c9a9 SHA512 52618df3453f10c49578df1a8a341978d4908c366f7af3975e8af85086d8f668ec42952fcab02b5e2166cff6020178fc015a0cb3038545979318014206d78471
-MISC metadata.xml 1086 BLAKE2B 5ead7194bab4b637946cc095ba6ae07eb461a20d4f8621f8be75c916e8d414a309b1679b928389e9e61f2ff4795a8f149b9a402f12bc21965d25df1251f6c4e3 SHA512 9867fb98eae499a7c149e61f37a08a27167d076cec8c85392c4a6db4bb8c44314f28771db8c35d1dc1f9ac1c8af21841503e12b0f0c3c39ae6be336a72096824
diff --git a/dev-python/numexpr/metadata.xml b/dev-python/numexpr/metadata.xml
deleted file mode 100644
index 2915727b034f..000000000000
--- a/dev-python/numexpr/metadata.xml
+++ /dev/null
@@ -1,29 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <longdescription lang="en">
- The numexpr package evaluates multiple-operator array expressions
- many times faster than NumPy can. It accepts the expression as a
- string, analyzes it, rewrites it more efficiently, and compiles it
- to faster Python code on the fly. It's the next best thing to
- writing the expression in C and compiling it with a specialized
- just-in-time (JIT) compiler, i.e. it does not require a compiler at
- runtime.
-</longdescription>
- <use>
- <flag name="mkl">Enable support for Intel Vector Math Library, part of
- <pkg>sci-libs/mkl</pkg>.</flag>
- </use>
- <upstream>
- <remote-id type="pypi">numexpr</remote-id>
- <remote-id type="github">pydata/numexpr</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/numexpr/numexpr-2.6.1.ebuild b/dev-python/numexpr/numexpr-2.6.1.ebuild
deleted file mode 100644
index 453de3de466f..000000000000
--- a/dev-python/numexpr/numexpr-2.6.1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Fast numerical array expression evaluator for Python and NumPy"
-HOMEPAGE="https://github.com/pydata/numexpr"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="mkl"
-
-RDEPEND="
- >=dev-python/numpy-1.6[${PYTHON_USEDEP}]
- mkl? ( sci-libs/mkl )"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
- # TODO: mkl can be used but it fails for me
- # only works with mkl in tree. newer mkl will use pkgconfig
- if use mkl; then
- use amd64 && local ext="_lp64"
- cat > site.cfg <<- _EOF_ || die
- [mkl]
- library_dirs = ${MKLROOT}/lib/em64t
- include_dirs = ${MKLROOT}/include
- mkl_libs = mkl_solver${ext}, mkl_intel${ext}, \
- mkl_intel_thread, mkl_core, iomp5
- _EOF_
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- if ! python_is_python3; then
- local -x CFLAGS="${CFLAGS}"
- append-cflags -fno-strict-aliasing
- fi
-
- distutils-r1_python_compile
-}
-
-python_test() {
- pushd "${BUILD_DIR}"/lib >/dev/null || die
- "${EPYTHON}" \
- -c "import sys;import numexpr;sys.exit(0 if numexpr.test() else 1)" \
- || die
- pushd >/dev/null || die
-}
diff --git a/dev-python/numexpr/numexpr-2.6.2.ebuild b/dev-python/numexpr/numexpr-2.6.2.ebuild
deleted file mode 100644
index 03821ec488ab..000000000000
--- a/dev-python/numexpr/numexpr-2.6.2.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Fast numerical array expression evaluator for Python and NumPy"
-HOMEPAGE="https://github.com/pydata/numexpr"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="mkl"
-
-RDEPEND="
- >=dev-python/numpy-1.6[${PYTHON_USEDEP}]
- mkl? ( sci-libs/mkl )"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
- # TODO: mkl can be used but it fails for me
- # only works with mkl in tree. newer mkl will use pkgconfig
- if use mkl; then
- use amd64 && local ext="_lp64"
- cat > site.cfg <<- _EOF_ || die
- [mkl]
- library_dirs = ${MKLROOT}/lib/em64t
- include_dirs = ${MKLROOT}/include
- mkl_libs = mkl_solver${ext}, mkl_intel${ext}, \
- mkl_intel_thread, mkl_core, iomp5
- _EOF_
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- if ! python_is_python3; then
- local -x CFLAGS="${CFLAGS}"
- append-cflags -fno-strict-aliasing
- fi
-
- distutils-r1_python_compile
-}
-
-python_test() {
- pushd "${BUILD_DIR}"/lib >/dev/null || die
- "${EPYTHON}" \
- -c "import sys;import numexpr;sys.exit(0 if numexpr.test() else 1)" \
- || die
- pushd >/dev/null || die
-}